2

I have installed the ClickUp on my Mac. It has very irritatingly changed the global key binding + E to create a new task in ClickUp. So every time I attempt to eject a hard disk from my Mac ClickUp comes to the fore with new task pop over open (ClickUp is not in the foreground so it is hijacking the global shortcut). This is beyond undesirable behaviour. I have tried finding this shortcut within the ClickUp settings but it appears no where in the app. I have asked ClickUp support (a couple weeks ago) and got radio silence. The System settings keyboard shortcuts shows nothing for + E. I have looked through the Application Support folder for ClickUp and in the app files (via Show Package Contents in Finder), and not found anything obvious for editing shortcuts.

If it makes any difference it looks like the ClickUp app is an electron app.

macOS: Ventura 13.1 ClickUp: Version 3.1.2 (3.1.2)

Do you know of a way to prevent ClickUp from using this key binding?

0

1 Answer 1

1

I agree, infuriating! There's a setting to turn that off and it's cleverly hidden:

• Click your avatar

• Click My Settings

• Two items below on the left-hand side menu, click Desktop App

• There you get to turn Cmd+J and Cmd+E off

Annoyingly, no re-definition is possible as these global hotkeys DO have value, just not on a commonly used keystroke like Cmd+J and Cmd+E. Terrible UX design!

Source: https://www.reddit.com/r/clickup/comments/wb4o2v/i_want_my_ctrle_key_combo_back_please_grindingly/

Someone from ClickUp participated there.

Also makes me slightly uncomfortable that an Electron app can monitor my keystrokes "just like that". I don't recall having given it special permissions to do so. And by "slightly uncomfortable" I mean very! 😂

1
  • That is well hidden! Thanks, this is a real help. I hope it helps others too.
    – Dan
    May 16, 2023 at 21:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .