I have a virtualbox setup I was using on catalina. I finally got around to reinstalling the machine and updating to Ventura.

The test suite (running in an Ubuntu vm) has gone from 26 minutes to over an hour, with no other changes. The VMs' are running without display. I have looked at other issues and many people have commented on the graphics, but, that shouldn't be an issue here.

I guessed (incorrectly!) that it might be to do with the new permissions model, so, I gave virtualbox full disk access and still no luck.

Is there some secret setting somewhere I can set to get it all working again? ;)


  1. This is a newly installed OS and newly created VM (vagrant destroy, vagrant up..)
  2. GuestAdditions 7.0.6 installed and running
  3. VirtualBox 7.0.6
  4. Mac -> 2.9Ghz Core i7. 16Gig ram
  5. Two VMs running Ubuntu 18.04, one with 3GB ram other with 4 (this is more than they used to have and ample for the boxes) Running free on the boxes shows they are not using swap.

Tried so far:

  1. Giving virtual box full disk access.
  2. setting display to none.
  3. setting config.vm.synced_folder "./foo", "/srv/www/local", type: "nfs", mount_options: ["actimeo=2"]

Option 3 may have sped things up (from about 68 minute to 48 minutes). Still hoping to get it back down to under 30 minutes (which is what it should be)

  • Virtualbox is upgraded too, and its extensions pack? You might consider rebuilding the VM in case something has changed in the virtual hardware model. This is usually especially relevant when it comes to virtual IO devices. Please also update your question with the other issues you have examined and rejected, so we don't have a Q&A session over what's been already tried. Also please add the Mac hardware details, and a brief summary of the VM settings. Feb 22 at 21:57
  • So it sounds like your problem is related to your synced folder? Is the server source located on the macOS and shared into the VM? That sounds like an extra layer just made for slowing things down... Feb 23 at 9:49
  • I ended up going with the rsync option which definitely improved things. Your comment about it being an extra layer slowing things down was helpful. With that said, I still think it's pretty bad that just upgrading an operating system can have that much of an effect on your test suite when it's all virtualized anyway. Feb 27 at 6:49

1 Answer 1


For me I ended up using the rsync option for the shared folder:

config.vm.synced_folder "./localfolder", "/srv/www/remote", id: 'code', type: "rsync", rsync__exclude: "./git", rsync__args: ["--verbose", "--archive", "--delete", "-z"], rsync__auto: true

That brought the test suite back down to ~35 minutes (still 7 minutes slower, but, not more than double the time at least)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .