17

The auto-complete features can be nice, but somewhere along the line my iPhone has learned some questionable language. How can I get the iPhone to "forget" certain words from its auto-complete settings / dictionary?

  • 2
    There's a similar question here. – Senseful Mar 23 '12 at 21:48

11 Answers 11

14

It sounds like it used to be possible to manually edit the user dictionary, but unfortunately it isn't anymore.

Just a guess, but perhaps you can have it forget them the same way it learned them — when it suggests the word, try tapping on the small [x] next to the suggestion. If you do this a few times it may "forget" the word.

You can reset the dictionary entirely by going to Settings > General > Reset:

  • Aw, you beat me by 6 seconds, and with a screenshot! I bow to your superior knowledge and skills. – Adam Davis Mar 23 '12 at 19:01
  • You beat me, too. – Andrew Larsson Mar 23 '12 at 19:01
  • 1
    I thought that tapping the little x by the word just meant "go away, don't replace this now". ? – KatieK Mar 23 '12 at 19:05
  • 1
    @KatieK: It does, but if you do it enough times I believe it learns not to offer the suggestion anymore. – jtbandes Mar 23 '12 at 19:06
  • 2
    Can anyone verify that it does? – Dante Mar 27 '12 at 8:33
6

I opened notes, typed the word I wanted and when the incorrect autocorrect showed I pressed the cross. I pressed space bar and repeated the process 8 times. On the 9th time the incorrect suggestion stopped showing. Now it doesn't suggest the incorrect word anywhere!

5

Go to Settings--General--Keyboard--Add New Shortcut

Put the CORRECT word in the phrase spot and the misspelled word in Shortcut spot. Every time you type the word the phone wants to autocorrect with the misspelled word, it will automatically default to the CORRECT spelling! It doesn't remove the word from the dictionary, but it beats the phone at its own game!

4

You can either erase all learned words by going to Settings > General > Reset > Reset Keyboard Dictionary, or you can have your iPhone automatically censor out bad language that you type. To do the latter, go to Settings > General > Keyboard > Edit. You can then set a "censor" for bad language. What you could do is create a new shortcut for when you type the Phrase "cheese", it'll automatically Shortcut to "ch***e."

3

The easiest way is to reset the keyboard dictionary:

SettingsGeneralResetReset Keyboard Dictionary

2

Short of a reset (as the other answers mentioned) or jail breaking, you can't :-(

There are a lot of tips to tuning it in this GigaOm article (including the name of the file to edit if you do jailbreak).

You can tune it by typing a word and insisting it is correct, you can add a word manually Through a somewhat hidden feature in international keyboard settings, but annoyingly the only way to make it forget is to forget everything.

1

For completeness, there's also this option which will make it not replace any words:

Turn off Auto-Correction:

  1. Launch the Settings app
  2. Go to General > Keyboard
  3. Turn off Auto-Correction
1

Found a solution to this. Opened notes, and commenced meeting in a word. Words I do not want appear on the banner above the keyboard. Just press and hold those words and you will be invited to remove the word from the dictionary.

0

I had an issue where every time I typed the name "Larissa" it would capitalize it to "LARISSA". No matter how many times I hit the "X" next to the suggestion, the thing just would not go away.

I discovered that I had a contact in my address book with the surname "LARISSA" (capitalized), and it was using this contact to make the correction automatically. As soon as I adjusted the contact, it no longer forced this capitalization.

It's possibly a rare case, but hope it helps someone else out there.

(Using iOS 9.3)

-1

You can create a keyboard shortcut. Settings>General>Keybord>Text Replacement. This may work for a word or phrase you use frequently. This may help in reprogramming the dictionary. It's an indirect way to edit the spell check function.

-1

add another English keyboard (e.g Canada / UK) and voilá

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .