1

I tried all the solutions mentioned in the below links but the MacPorts group is still there:

➜  ~ dscacheutil -q group | grep "macports"
users: root myusernameeee macports _nsurlstoraged _serialnumberd

The only remaining thing from MacPorts is the group. there is no user as MacPorts anymore after running delete commands.

I have tried these:


  • I tried to reinstall MacPorts and then uninstall it again but didn't help.
  • I migrated from an Intel MacOS to a Silicon MacOS and MacPorts had created during that process; I had not installed MacPorts before migration.
  • Both OSs before migration had the same OS version: Ventura 13.2.1
  • During the migration process, when Migration Assistant said you could give a password to your own user or I create a temporary user, I set a password for my own user
  • I didn't give admin privileges to the temporary user (there was a button in front of the temporary user to give that permission)
  • As I had not installed MacPorts by myself before migration, there was on MacPorts application; so, sudo port -fp uninstall installed resulted port: command not found
  • MacPorts user is not at the login screen and Settings->Users&Groups.
  • Running sudo ls /var/db/dslocal/nodes/Default/users results: daemon.plist,myusernameeee.plist,nobody.plist,root.plist

Update:

➜  ~ dscl . list /Users | grep -v '^_'
daemon
myusernameeee
nobody
prey
root
➜  ~ /usr/bin/dscl . -search /Users name macports
➜  ~
sudo ls /var/db/dslocal/nodes/Default/users

...
_jabber.plist           _www.plist
_kadmin_admin.plist     _wwwproxy.plist
_kadmin_changepw.plist      _xserverdocs.plist
_knowledgegraphd.plist      daemon.plist
_krb_anonymous.plist        myusernameeee.plist
_krb_changepw.plist     nobody.plist
_krb_kadmin.plist       prey.plist
_krb_kerberos.plist     root.plist
_krb_krbtgt.plist
➜  ~ sudo /usr/bin/dscl . -delete "/Groups/macports"
delete: Invalid Path
<dscl_cmd> DS Error: -14009 (eDSUnknownNodeName)
➜  ~ dscacheutil -q group | grep "macports"
users: root myusernameeee macports _nsurlstoraged _serialnumberd
➜  ~ sudo find /Volumes/External -user macports
find: -user: macports: no such user
➜  ~ sudo find ~ -user macports
find: -user: macports: no such user
7
  • Doesn't the dscacheutil -q group show macports is a user not a group - which group is it a part of? I don't see that setup in my Ventura
    – mmmmmm
    Feb 19, 2023 at 9:10
  • I see your comments on apple.stackexchange.com/a/320714/237 - try removing the user macports
    – mmmmmm
    Feb 19, 2023 at 9:15
  • dscacheutil -q group -> name: staff password: * gid: 20 users: root myusernameeee macports _nsurlstoraged _serialnumberd. Whether it is a group or a user, how to delete it? Cause I do not have it in login scree, or Settings User&Group either
    – Dr.jacky
    Feb 19, 2023 at 9:18
  • 2
    Based on your comments, this indeed is a duplicate of apple.stackexchange.com/questions/317576/… (all your dscacheutil output shows that there is a user macports belonging to group staff). Please follow the steps in the accepted answer there to remove the user.
    – nohillside
    Feb 19, 2023 at 13:34
  • If these steps fail, please copy/paste the whole part (all commands and their output) into the question and flag it for reopening (or mention me in the comments here).
    – nohillside
    Feb 19, 2023 at 13:36

0

You must log in to answer this question.

Browse other questions tagged .