2

This is on my Wife's Intel MBA with Ventura 13.2.1. She had a problem importing an ics file from an online source that works fine on my MBP.

Upon closer investigation her Calendar (iCloud) was completely empty of events and if I tried to add the event from the ics file I got an odd error message:

Import failed to save

Investigating further it seems that if I try to add an event to the calendar, nothing happens, literally. Selecting File → New Event or clicking on the "+" button there is no response from calendar.app.

Then I notice (duh) that there are no calendars listed in the sidebar, So I try File → New Calendar and get this:

This calendar can't be added

Now I go into Calendar's Accounts Preference pane and remove and then try and re add her iCloud calendar (there are two Gmail accounts there but they are disabled there, and calendars are turned off in those accounts in System Settings) but when I try and log in it says her iCloud account is locked for security reasons... Grrr...

I log into her iCloud account, reset the account password and try again. Having verified that calendars are turned on in System Settings → iCloud and that her calendar app is working just fine on her iPhone, none of her calendars show up in the sidebar (and I still can't add an event). Which makes some kind of sense as there are no actual calendars to display besides the default calendar that is displayed when there aren't any calendars.

There was one lone Calendar.app preference file in the ~/Library/Preferences folder which I deleted with no detectable change in behavior and I did not find any other preference/settings files anywhere else in ~/Library or /Library.

I am a loss as to why the calendars that display fine on my wife's iPhone are MIA on her MBA

6
  • Out of curiosity...If you disable all syncing of the Calendar on the iPhone, can you create a new calendar event in iCloud (web interface)?
    – Allan
    Commented Apr 5, 2023 at 22:06
  • 1
    If I disable syncing on the phone and I lose even ONE calendar entry for my wife y'all will be holding the first AD online funeral for a member ;-) So while I see the possible utility of doing that, I would rather keep the solution to just the Mac, on which the calendar is not working and leave the working iOS calendar alone. Commented Apr 6, 2023 at 20:07
  • Backup anything important (for example, the calendar events) and then wipe the hard drive and reset it to factory settings. Here is a tutorial on how to do it: support.apple.com/en-us/HT212749.
    – GroxDots
    Commented Apr 10, 2023 at 14:28
  • What type of user account does your wife have on this computer? Admin, or something else?
    – sdmeyers
    Commented Apr 10, 2023 at 17:33
  • It's an admin account. And wiping the hard drive and starting from scratch is a non-starter, she can't do without the Mac and the calendar is fine on the phone so getting it working on the Mac would be helpful, but she is used to doing calendar things exclusively on the phone. And these days with the SSV reinstalling the OS doesn't do what it used to. Commented Apr 10, 2023 at 20:25

1 Answer 1

1

Exactly the same here; could not add a calendar either, a read-only account. On my machine, the directory ~/Library/Calendars was owned by root. That is not correct, looking at another macOS system. Fixed it with:

sudo chown -R <username>:staff ~/Library/Calendars

I'm not sure how this happened, it's a relatively new machine, maybe the transfer of data and settings from the old machine failed somewhere.

Update: When I had fixed it with the command line, my Gmail address calendars were back quickly, but not the iCloud ones. I got an unexpected error (sic!):

Your calendar couldn't be refreshed:
There was an unexpected error with the request (domain DAErrorDomain / error 6).

I needed to sign out and in of my AppleID to fix that.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .