1

PROBLEM...

  • After upgrading to Monterey from Big Sur, my 2019 Intel Macbook Pro won't connect to an SMB share on my FujiXerox RIP (FXServer).
  • Nothing else has changed since running Big Sur on the same Macbook Pro. This Macbook is connected via ethernet over a thunderbolt dock which has worked fine for years.
  • A 2013 Macbook Pro running Mojave on the same network has no issues. It's connected via an Apple TB 2 Ethernet adapter.
  • I usually connect by hitting CMD + K, double-clicking the share (smb://fxserver/SCAN) and /SCAN would mount with no login etc

HAVE TRIED...

Steps from this post: https://forums.macrumors.com/threads/smb-broken-with-monterey.2324371/post-30668058

1

As noted above I added a nsmb.conf file to /etc containing the following...

[default]
protocol_vers_map=6

Then restarted but it keeps asking me for login credentials and failing (guest doesn't work either). This is just a scan folder from our FujiXerox RIP that requires no login. This is how the other Macbook Pro connects as well.

2

As noted in the post above, I also tried adding signing_required=no to the conf file like this...

[default]
protocol_vers_map=6
signing_required=no

And restarted but still no joy.

3

I then tried adding port445=no_netbios as noted here: https://support.apple.com/en-us/HT211927

[default]
protocol_vers_map=6
signing_required=no
port445=no_netbios

But that wouldn't even attempt to connect so I removed it.

4

This articles suggests checking the SMB version: https://lemp.io/how-to-check-smb-version-mac-os/

But when I run the command from the article, it doesn't seem to exist...

defaults read /Library/Preferences/com.apple.smb.server SupportedProtocols
2023-02-17 16:05:16.412 defaults[2258:18483] 
The domain/default pair of (/Library/Preferences/com.apple.smb.server, SupportedProtocols) does not exist

5

This post suggested adding .local to the address: https://forums.macrumors.com/threads/update-resolved-brand-new-m1-macbook-pro-does-not-see-any-other-macs-or-network-drives-can-anyone-assist.2334034/post-30840040

But this didn't work: smb://fxserver.local/SCAN

6

This post suggests a ktext is the culprit: Mac mini can't connect to my corporate SMB server. Was working some days ago

But I don't seem to have it installed unless I'm reading this wrong.

kextstat | grep -iv apple
Executing: /usr/bin/kmutil showloaded
No variant specified, falling back to release
Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>

7

Have tried flushing the DNS cache using...

sudo dscacheutil -flushcache; sudo killall -HUP mDNSResponder

8

Tried smb://fxserver.home/SCAN & smb://fxserver.local/SCAN as well as the IP address instead. No joy.

9

Also tried shutting down, waiting a minute then restarting.


QUESTIONS...

1

Because no SMB supported protocols exist, does that mean that SMB is somehow not installed?

2

This is a clean erase and upgrade to Monterey that's about a week old, do I need to enable SMB somehow?


OTHER...

  • Sorry, I'm not knowledgeable about SMB at all. This has worked automatically for years without problems.
  • Nothing else with the network, printer, share, router has changed.
  • The other Macbook Pro running Mojave has no issues and before the upgrade from Big Sur, this Macbook had no issues either.
  • I'd previously hit CMD + K, double-click the share at smb://fxserver/SCAN and the SCAN share would mount - no login etc.

Sorry if I'm missing something basic, any help or suggestions much appreciated.

8
  • (From many, many years ago….) I stopped using the default .local domain as it wouldn’t play nice with Active Directory. If your org uses an internal domain name (eg: I use .home at my house) try using that. So, your Fujitsu should be smb://fxserver.domain/SCAN. Also try connecting via IP address to skip DNS resolution altogether.
    – Allan
    Commented Feb 17, 2023 at 18:40
  • Thanks Allan, much appreciated. Just tried .home but it doesn't connect at all. .local connects and asks for credentials but even the server admin password doesn't work, neither does guest. And the IP address does the same thing, it asks for credentials but it won't connect. Totally confused sorry, I'm not knowledgable about this stuff at all sorry.
    – CMSCSS
    Commented Feb 17, 2023 at 19:23
  • .home is what I use at my house. I’ve set up my network domain this way. Your network/server admin should have setup a local domain for use there. For example, Microsoft has the public domain microsoft.com, but internally, they use .msft (I’ve spent too much time in their offices). Find out what your company uses and append that to the hostname. Try the command hostname or uname -n to get your hostname with domain
    – Allan
    Commented Feb 17, 2023 at 19:39
  • Thanks Allan but we work from home and the printer was setup by Xerox. Another Mac can connect using smb://fxserver/SCAN and so did this one until it was upgraded to Monterey. I can't change the Xerox as I don't understand how, besides the other Mac connects fine. Does anyone have specific info on what changed in Monterey to break this stuff? And instructions to get it working again? Or info I could pass along to Xerox so they can change the RIP's config?
    – CMSCSS
    Commented Feb 18, 2023 at 0:10
  • I'm experiencing the same thing after updating to the latest Ventura. Did you find a solution? Commented Feb 21, 2023 at 21:36

1 Answer 1

1

Thanks to a pointer in the right direction by @user3071284 here are the exact steps to fix...

  1. Open Terminal
  2. Run the following sudo nano /etc/nsmb.conf
  3. Enter account password
  4. Add the following text to the file as shown...
[default]
protocol_vers_map=1
signing_required=no
  1. Hit CTR + X
  2. Hit 'Y' to save
  3. In the Finder, hit CMD + K
  4. Enter the server address e.g. smb://fxserver/SCAN
  5. Connect as a guest (still can't get the registered user to work)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .