0

I've enabled Develop menu but when I click it, it takes around 1.5 minutes to open.

This behavior was not happening at the beginning but started after a while, presumably around the time I inspected my iPhone simulator through Safari.

I disabled cache, reset settings and restarted, but none of these have solved the problem. I have no extensions installed in Safari.

This is the screenshot of the Console app's logs: Console logs

4
  • Have you tried deleting Safari's preferences (i.e. .plist)?
    – agarza
    Commented Feb 14, 2023 at 3:20
  • @agarza No, how do I do that? Commented Feb 14, 2023 at 7:24
  • Generally preferences are in the ~/Library/Preferences folder. There are a couple of Safari preferences there like com.apple.Safari.plist. There may be others that control that preference in other locations in ~/Library or /Library Commented Feb 14, 2023 at 15:31
  • Yes, I tried deleting them (total 4 files) but didn't work. Commented Feb 17, 2023 at 9:11

1 Answer 1

1

After a lot of hair pulling, I finally figured it out.

Checking Console apps logs, I saw a lot of SafariBookmarksSyncAgent timeout errors.

So I unchecked the Safari option from iCloud sync options, and it worked. It appears that there's an issue with syncing bookmarks.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .