2

I want to zip a folder (any folder). When I try to do so I get:

couldn't communicate with a helper application

Also, when I try to copy any folder I get exactly the following:

Finder can’t complete the operation because some data in “” can’t be read or written. (Error code -36)

I've tried

  • restarting finder
  • restarting the computer
  • shutting down and then re-opening the computer
  • checking file and folder permissions (both read and write)
  • showing hidden files, none show up
  • running dot_clean command

Both errors persist and only apply to folders (copying/zipping files is fine). I have no idea/direction on how to solve them. I can only think it could be related to having recently changed my Apple ID password. The Terminal zip command works fine on both folders and files.

2 Answers 2

0

The problem seems to have solved itself after I loaded a time machine backup i had from two weeks ago. I have not found the cause but it seems to work fine for now.

0

On my end this issue still persists and has not solved itself. I have changed my macOS username at one point and I cannot remember for sure if this issue started occurring after that change.

Workarounds I have implemented since to still be able to compress things are:

  1. Using Keka
  2. Using zip from the command-line

I would be grateful to anyone with a solution to the root-cause of this problem that could contribute it to this thread.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .