1

I've noticed over the last few months that every few days, my M1 Pro MacBook Pro loses internet access even when successfully connected to a WiFi network. For example, earlier today I couldn't access the internet on my browser. I went to my WiFI settings and saw the following:

enter image description here

In iStat Menus, however, it seems like there is some minimal WiFi network usage (however, I can't confirm if this is internet usage):

enter image description here

When I try the ping command in the Terminal, it seems to error out:

enter image description here

The only way to get connected to the internet again is by rebooting my MacBook, which is often a hassle. Some other things that I've tried are as follows:

  • Logging out and then back in
  • Logging into a different user account – experiences same issue
  • Renewing DHCP lease from the WiFi's preferences
  • Resetting network preference files
  • Checking date and time preferences
  • Quitting my VPN app (Mullvad)
  • Disabling my firewall network filter (Little Snitch)

This seems to happen across a variety of networks, including public and private ones. This issue occurs erratically—at times I will go for a few days without facing this issue (although this is rare), but at other times I'll experience this issue every day. This issue only seems to happen upon changing WiFi networks—no matter what type of network I switch to.

Is there any good way to troubleshoot exactly why my MacBook Pro regularly and seemingly randomly loses connection to the internet so that I can find the root cause of the issue?

macOS seems to have a network diagnostics tool, but it does not seem to be able to troubleshoot issues like the corresponding tool on Windows can.

6
  • YaleSecure sounds like a captive portal. If it is something that requires a login, you would have IP communication to the portal, but that doesn't mean you would have communications to the Internet. Feb 7, 2023 at 20:19
  • I'm thinnking that this is DHCP lease related. Instead of rebooting, try releasing and renewing the lease (under TCP/iP). Alternatively, you can disable then re-enable the interface. If it starts working again, then we need to investigate your DHCP.
    – Allan
    Feb 7, 2023 at 23:16
  • Thanks for the suggestion with the DHCP—I tried resetting it but it looks like it didn't fix it. Moreover, I've noticed recently that if I stay at one WiFi network (e.g. home or school) for more than a few days, it'll stop working on the new WiFi network, even when I renew my DHCP lease, unless I restart the computer. Perhaps there's a way to restart the network service on a Mac without needing to fully restart it all the time?
    – Oion Akif
    Mar 8, 2023 at 11:54
  • See if your VPN kill switch might be the culprit. (Mullvad FAQ link)
    – pwn'cat
    Apr 12, 2023 at 8:18
  • @pwn'cat Thanks for the suggestion! Unfortunately I have safely been able to rule out the VPN issue, as I don't use the killswitch on this device and the issue persists even after quitting or trying to reconnect in the VPN app
    – Oion Akif
    Apr 18, 2023 at 0:06

2 Answers 2

1

The router, the network service provider, and the Mac are typically the main culprits in most cases. Take a look at this guide. It listed some possible causes and fixes for Mac connected to WiFi but no internet.

1
  • Unfortunately none of the solutions listed solved the issue
    – Oion Akif
    Apr 8, 2023 at 21:35
1

Try turning off "Limit IP address tracking". This is a great feature, but it has issues with many network functions that may be tracking you for non-nefarious reasons. (Also if you are using a VPN it's a bit redundant).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .