8

For some reason, Image Capture doesn't always update the list of devices after I plug in my iPhone. Sometimes restarting Image Capture works, and sometimes it does not. Does this have to do with the number of images on my iPhone, which is several hundred? The fact that there's a passcode on my iPhone?

Is there a steady way to make my iPhone appear?

Edit:

The iPhone is indeed visible in iTunes. Connecting via the other USB port makes it visible in Image capture as well - after a wait.

  • Not an answer-yet-Neither the number of images on the device or he passcode are a factor in having the device itself mount—appearing in the device list. The image count does make a difference in the amount of time it takes for the image files to appear in the right hand window of Image Capture. Is the iPhone visible within iTunes when it's not available to Image Capture? Can you see the iPhone from System Information/System Profiler? My gut instinct—use a different dock cable and a different USB port—and plug directly into the Mac for testing. – jaberg Mar 23 '12 at 14:52
  • @jaberg - See my edits. – Moshe Mar 23 '12 at 15:26
  • 1
    Image Capture has always taken a couple of minutes to detect my iPhone. I believe it's just poorly written to handle new devices. – sudo rm -rf Mar 24 '12 at 17:03
  • 1
    Yes it takes a while for my iPhone 4 on 10.8. Do you want to answer your own question? Sounds like it is that particular USB port that is problematic just a little? – NOTjust -- user4304 Apr 23 '13 at 18:50
3

If you quit the application and re-start it, that seems to resolve any devices that connect and get missed when you plug them in after the application has launched and enumerated the connected USB devices.

Even if you have iTunes and Xcode and other apps running, I've not seen Image Capture fail to recognize connected devices if you restart the program and I have certainly seen it miss device connects on occasion when other apps are running and want to talk with an iOS device.

That being said, here are things to check:

  • Different USB ports and cables
  • Trust setting on the iOS device (Settings -> Reset -> Reset Location & Privacy.)
  • restart either the phone or the Mac or both
  • update software on the phone or the Mac or both (iTunes updates install sync software and drivers needed)
  • make a new account on the Mac (to test once) in case image capture or your photo library settings or data are corrupt

See https://support.apple.com/en-us/HT202778 for trust issues and iOS.

  • annoying thing is that Image Capture takes an age to load if you have iCloud Photo Library switched on, with a lot of photos. Relaunching Image Capture is SLOW. – Jowie Apr 25 '16 at 16:01
  • what helped me was a variation of your "Different USB ports and cables" - I had to connect a different apple device to the same USB port. (see my answer below). Thanks! – drpawelo Jul 31 '17 at 11:19
  • This also applies to Adobe Lightroom. – Eric O Jul 7 at 22:45
2

Connecting the device via another USB port (or in my example via USB hub, connected to another port) was the only thing that helped me.

What did not work for me was: - Force Quit and restart the Image Capture - Restart the computer - Opening/using iTunes

1

On my iPhone, I had to go to Settings -> Reset -> Reset Location & Privacy. Once I reset this setting on my phone, I got a prompt on my iPhone asking if I wanted to trust the computer I was connected to. After I tapped the Trust button, all of my photos appeared.

0

a restart worked for me! then restart itunes, disconnect and reconnect phone, open image capture... but when the app is open select "image capture" on the drop down far bottom left.

0

It wasn't showing in Image Capture to me. What I was missing was to sync my iTunes and my iPhone (as I has recently upgraded to Yosemite). Syncing both solved the problem to me. Right after, I opened Image Capture again and my iPhone was there and all the photos were showing.

0

My resolution was to quit and reopen the Image Capture application. My iPhone then appeared as a connected device. In Image Capture, I then selected the device from the right sidebar and clicked on the triangle icon at the bottom left of the application's window. I set this to "No application" when the iPhone is connected. This way I don't have Image Capture automatically open with the device not appearing there and can choose to open Image Capture as I please after plugging in my phone and it has loaded.

0

I just tried closing iTunes, then closed and reopened image capture and bingo - iPhone showed straight away. May work for others

  • 1
    Thats with 37+ gig of photos on the phone :-O – Josh Sep 20 '15 at 2:56

You must log in to answer this question.

protected by bmike Jul 25 '17 at 11:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .