2

I can type into a cell "40 year old virgin" but I can't put in "48 hours" as it gets changed to "2d".

What nonsensical setting is making this happen?

Also if I type in "21" (for the Movie 21) it right aligns, so I think it is also doing the same weird thing.

Screenshot of Numbers table showing problematic cells with contents "21" and "2d" right aligned.

2
  • 2
    I suspect that Numbers is taking the title "48 Hours" as a temporal number and shortening it to "2d" to represent two days. Something similar is happening with the movie "21"; Numbers is assuming a number and not a character string.
    – agarza
    Jan 28, 2023 at 3:38
  • Try wrapping the value in quotes
    – bjbk
    Jan 28, 2023 at 3:55

1 Answer 1

10

By default, Numbers formats table cells automatically. If you enter only a numeric character, it assumes it is a number and displays it accordingly. Entries that look like durations are automatically displayed under the most appropriate duration format.

If you want automatic formatting not to apply to certain cells, you should set the formats for those cells using the Data Format option under the Format -> Cell sidebar menu, preferably before starting to enter the data.

If you are entering movie titles, for example, format the cells to hold the titles as Text beforehand. If you do that, neither "48 hours" will be recognized and displayed as a duration nor "21" will be displayed as a right-aligned number.

Another way to make sure what you are entering in a cell is recognized as text even without formatting is to type a single quote ' first.

See the “Format dates, currency, and more in Numbers on Mac” Apple support webpage for more.

1
  • 2
    Also note that ALL spreadsheet programs have this same behavior and generall solution: change the formatting of the cell(s) Jan 29, 2023 at 0:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .