I run High Sierra on my old Mac. Importing pictures from my iPhone running 15.7.2 was never a problem.

Roughly since December 2022, I haven't been able to import photos. The error message is always the same: Unable to import due to unknown format.

The pictures are in HEIC and I have HEIC pictures on my Mac from previous imports and I can still open these.

My Mac knows the format, but the Photos.app somehow has stopped recognizing it. Perhaps it's a deeper problem and the format is just "an excuse" but the app is now unable to import anything?

  • Have you tried Image Capture instead?
    – Tetsujin
    Jan 27 at 10:42
  • @Tetsujin If I try to import all the pictures at once, I get a similar error message. If I import just one, it hangs.
    – ATN
    Jan 27 at 15:42
  • Not really sure what to suggest. Maybe try re-laying the OS from recovery. That should leave all your data intact, merely refresh the OS itself. [As with any operation like this, a solid backup is always wise.]
    – Tetsujin
    Jan 27 at 16:06
  • 1
    It seems I'm not the only one having this problem since November: From the German forum: macuser.de/threads/…
    – ATN
    Jan 28 at 21:45

1 Answer 1



Switching to a reliable USB-lightning cable (from Apple or Anker which is good enough) worked and I could import my photos without problem.

I believe that the error message is quite misleading. It probably has nothing to do with the format of the images (as both JPEG and HEIC seem to have a problem).

I went into the Console.app and had a look at the logs from the Photos.app and one error kept coming up

ERROR: Der Vorgang konnte nicht abgeschlossen werden. 
(com.apple.ImageCaptureCore-Fehler -9912.) (, path: IMG_7156.HEIC 
(IMG_7156.HEIC)), file: /BuildRoot/Library/Caches/com.apple.xbs/Sources
/RKImageCaptureManager.m, line: 777

According to the thread post linked below, the error could be a read-write error linked to a low-budget lightning cable.


It's not exactly the same number but I gave it a try. Looking back, I remembering breaking my iPhone cable in November and bought a cheap one on December 2, which fits my time window since the bug appeared.

Switching to a reliable USB-lightning cable (from Apple or Anker which is good enough apparently) worked and I could import my photos without problem.

  • 1
    If changing the cable solved your issue, it was likely due to using a charge only cable, that's not meant for data transfer. Some of these cheaper cables do have limited data x-fer capability; trying turning them over (flip the connector 180°)
    – Allan
    Jan 29 at 22:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .