0

I am stuck with WiFi-connection problem after a Ventura update. I am using an external monitor LG 34GN850-B.AED, connected using DisplayPort.

With previous ISO everything worked pretty well. Now, when I connect my MacBook Air 2022(M2 proc.) to my monitor, the WiFi drops. It does not turn off on its own, the connection is just unstable. It’s like the cable blocks WiFi signal. I want to point out, that when I use my Mac without the monitor - WiFi speed and bandwidth is perfect.

I wrapped my cable by metal foil. This helped, but of course looks pretty strange and not very safe. Is anyone familiar with this type of problem and know of a fix?

15
  • It sounds like the cable you are using isn’t shielded. If it’s a basic generic cable, it’s the manufacturer didn’t use shielding to lower costs. Try getting a new cable from a reputable brand like Belkin, Cables2Go, or Anker. they are more expensive, but there is a reason for it.
    – Allan
    Commented Jan 24, 2023 at 13:51
  • amazon.de/dp/… - I use this one. The problem is that I want to use 144 hz.
    – Morkovka
    Commented Jan 24, 2023 at 14:03
  • They are no longer available. This is a red flag for me. Try this one: amazon.de/-/en/…
    – Allan
    Commented Jan 24, 2023 at 14:07
  • So this cable now is very bad? Due to the update? My Monitor is ultra wide and 144 hz. Will it possible to use 144 hz with this cable?
    – Morkovka
    Commented Jan 24, 2023 at 14:20
  • When a seeming good product is suddenly unavailable, it usually points to an shady seller. Ever since I started sticking with reputable brands, all the weird issues disappeared. If the cable was “updated” they could revise the listing. .
    – Allan
    Commented Jan 24, 2023 at 14:24

1 Answer 1

1

I want to answer my question for people, who has also encountered with this kind of problem.

I am not sure that the special kind of cable is quilty (only if it is poor-quality cable for 4-5 dollars), because I have bought a new one by Belkin (I think there's no need to hesitate about its quality) and plugged it. It fixed my issue for approximately one month, but yesterday the problem has popped out one more time!

Just try to turn off AWDL-service (this is AirDrop, CarPlay and so on) by using command sudo ifconfig awdl0 down. If you need to turn in on - use sudo ifconfig awdl0 up. It helped me and the quality of internet connecting has become better (and it no longer suddenly falls off). Unfortunately it will terminate some functions. If these ones are vitally important for you, then you have to look for another solutions.

In my opinion, it is not a hardware problem, more likely software issue after macOS Ventura has been released. So, also I would like to recommend regularly update your macOS and probably it will bear fruits and Apple will manage to solve this disgusting issue.

If you have any cleaning-programs, such as Clean MyMac of something like that, try to reset DNS-cache and just run a service script.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .