6

This is essentially a duplicate of Permanently Dismiss "New iCloud Terms and Conditions" on MacOS High Sierra except that my question is for the newest OS (I'm using 13.1), as it seems the problem has gotten worse in the intervening years, and there is also no longer an "iCloud" entry under system settings as described in the linked answer.

I don't use iCloud, I don't want to use iCloud, I will never want to use iCloud. And if that weren't enough, this is my work laptop and I legally can't use iCloud even if I wanted to.

Nevertheless, I get this popup multiple times per day. After clicking the notification to view the terms, the only options are "accept" or "cancel." If I cancel the popup just appears later anyway. If I dismiss the original notification by clicking the "X" the system settings will pop up and show me the terms and conditions anyway, taking another two clicks to get rid of them.

How can I disable this from showing up?

(Bonus if you can also answer for iOS, as I have the same problem on my iPod running iOS 15.7.1 and no way to permanently dismiss and disable iCloud there either.)

3
  • 1
    You don't mention of you had actually tried the instructions in the AskDifferent link you posted. Did it not work? If so, please edit to include this info.
    – IconDaemon
    Jan 24, 2023 at 1:54
  • @IconDaemon updated.
    – Wildcard
    Jan 24, 2023 at 2:12
  • Ventura System Settings is very different than pre-Ventura System Settings. At the very top is your Apple ID section, where you can find iCloud and other settings. I do not have a Venture Mac handy, but you can find out more about System Settings here. Scroll down Apple ID Settings.
    – IconDaemon
    Jan 24, 2023 at 2:35

2 Answers 2

9

System Settings -> Internet Accounts -> iCloud account (will likely be shown as "inactive" if like me you're not using it at all for anything).

Click it. Scroll down to the bottom. Click "Delete account."

1
  • 2
    After doing this, I get a different message periodically, "Update Apple ID Settings — Some account services will not be available until you sign in again."
    – Wildcard
    Jan 30, 2023 at 19:07
0

If you don't want to permanent delete it you may also click in the System Settings in the Top Most Position with your Picture / Name and Email.

There you can in the last line log-off from iCloud and also de-select the sync for single applications.

2
  • 1
    Do you know if this will actually turn off the notification? My iCloud account was marked as "inactive" and had no sync set up with any application ever, but I still had the notifications.
    – Wildcard
    Jan 24, 2023 at 23:01
  • I am not shure. From the client pc you should not get more messages, but I don't know what is apple triggering from the outside. But it is worth a try. Jan 25, 2023 at 4:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .