1

I deleted a partition using the diskutil command and now I can see the free space with diskutil list. However I cannot see the free space with the Disk Utility application.

How can I merge this free space (422.5 GB) with the current APFS partition?

enter image description here enter image description here

8
  • 2
    Did you exit Disk Utility and reopen it? Also, please don’t post photos of your output. Take a screenshot of your GUI app and copy\past text output to your question. You can pipe the output directly to the clipboard. Example: diskutil list | pbcopy then paste (Cmd-V)
    – Allan
    Jan 23 at 20:19
  • Ahh interesting, so I can copy paste in the recovery mode... Amazing indeed. Ah ok, I just checked. pbcopy: command not found Jan 23 at 20:22
  • % type pbcopy[return here] pbcopy is /usr/bin/pbcopy[return here] %
    – dan
    Jan 23 at 20:32
  • Normally while in recovery, I open Terminal window to enter commands, then close this window before opening the Disk Utility. If this is what Jamie (the OP) did, then exiting the Disk Utility and reopening (as Allan has suggested) would be pointless. Jan 23 at 20:50
  • pbcopy is not a command is displayed on all those commands sadly. Jan 23 at 20:53

1 Answer 1

1

To merge, there can be no partitions in between. In this case, there is the EFI partition (disk0s3) named EFI - ASAHI. The command below would remove this partition.

diskutil eraseVolume free none disk0s3

You could then use the command below to add the free space back to the APFS partition (disk0s2).

diskutil apfs resizecontainer disk0s2 0
2
  • Brilliant thank you very much indeed David!! This worked and was extremely easy Jan 23 at 20:55
  • Good to know the answer worked. However because the answer worked, this question is probably a duplicate of many previous questions and probably should be closed as such. Jan 23 at 21:37

Not the answer you're looking for? Browse other questions tagged .