When I tried to make an outgoing call on my (Ventura 13.1) MacBook Pro, the call failed with the message:

Your iPhone and Mac must be on the same Wi-Fi network

I checked that the iPhone 7 is using WiFi data from the same WiFi network. There is only one WiFi network that even works for me (i.e for which I have the password) at this residence.

There is a similar question here Facetime audio calls not working using iPhone but the situation (and the answer) are different from mine. In my case the WiFi network has not been changed for years.

Note: I can receive calls without issues.

So what needs to be done to resolve this?

  • Is your Wi-Fi network isolating nodes (devices)? Do you have a firewall running on your Mac? If the two devices are on the same network and can’t see each other, then something is blocking the communication.
    – Allan
    Commented Jan 19, 2023 at 17:14
  • The wifi network is not isolating nodes, but I am connected to a vpn on the Mac. I wonder if that's interfering? The thing is, i've connected to [big] corporate vpn's in the [recent] past and yet still been able to make calls. this is a different client on a different mac, but i'm not sure what the key difference is in the setup Commented Jan 19, 2023 at 17:21
  • 2
    Yes, the VPN is interfering. The moment you make the VPN active, you become part of that network and all traffic goes through that (tunnel) interface. Your Mac can no longer see nodes on your network because it’s technically no longer a part of it; you’re on the VPN network now.
    – Allan
    Commented Jan 19, 2023 at 17:51
  • actually a call now just worked. Looks like it's actual intermittent weakness in the wifi signal . Commented Jan 19, 2023 at 18:03
  • 1
    Most (corporate) VPNs route all traffic through the tunnel. It can be configured to share the connection. However, the VPN tunnels are notorious for being bandwidth hogs. If you have weak WiFi, then everything will have latency especially when a VPN tunnel is being kept alive. Kill the VPN and test calling. If the problem goes away, it’s your VPN
    – Allan
    Commented Jan 19, 2023 at 18:18

2 Answers 2


There are several factors that can influence whether devices (in your case, an iPhone and a Mac) "see" each other on a Wi-Fi network. This is required for Handoff like transferring a call from your iPhone to your Mac.

  • Wi-Fi signal stability. A poor signal means less bandwidth and higher latency. If the discovery (broadcast and response) packets get dropped it's like you not answering the phone thus the "I can't find you" problem.
  • Wi-Fi client isolation. This is a security feature of Wi-Fi network hardware like APs that prevent client devices from seeing each other.
  • An active VPN tunnel (from comments). Typically, VPN tunnels will route all traffic (default route) of the client through the tunnel; some can split the tunnel and allow local traffic to stay on the local network (policy configuration). If a VPN is active and is configured to be the default route, then the device is technically on a different network. Therefore, the devices can't see each other.
  • Bandwidth limitations. A VPN can consume much more bandwidth than you realize. Remember there's the overhead of the headers (creates the tunnel) and the encrypted data.

The Problem in a Nutshell...

Based on the comments, it sounds like you have multiple factors plaguing you:

  • Weak Wi-Fi signal that reduces the available bandwidth
  • An active VPN connection that could
    1. Route all your traffic through the VPN
    2. Consume most/all bandwidth resulting in severe latency.

What to do...

First, disable your VPN. If Handoff starts working, you know your VPN is contributing to the problem. If you can, take your Mac to place with good Wi-Fi signal strength and test out Handoff while the VPN is working. If the problem goes away, it's a bandwidth issue. If the problem persists while the VPN is active, it's a traffic routing issue.

  • This has never worked. The signal strength varies and I did sometimes use a vpn but given this never works - while at the same time I can receive calls indicates there are other things going on here Commented Apr 3, 2023 at 19:25
  • fyi It does not work even with the vpn disabled Commented May 31, 2023 at 17:39

I just turned off.

Wi-Fi client isolation

Now my problem is solved :-)

enter image description here

  • 1
    How did you get to the SSID Configuration dialog? Commented Oct 21, 2023 at 6:07
  • That is going to depend on the router
    – mmmmmm
    Commented Oct 21, 2023 at 6:12
  • Just browse router page by it's ip address. Generally it's like or etc. And just find the wireless / wifi settings option. Commented Feb 15 at 10:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .