1

So I'm at a loss with my Imac which suddenly wouldn't log in and I really really don't want to lose all the information I have on there. I've tried to be as detailed as possible but might have forgotten some things, so ask away if there's something missing etc. Also, I did do a minor back-up a few months before on the most essential things but far from everything and without the latest files.

Problem:
When I try to log in to my main (admin) account the computer gets stuck only showing the account name and picture, with a wheel that won't stop turning. At first the wheel freezes and a spinning beach ball appears for a few seconds before disappearing again, whilst the other wheel continues. Then it stays like that. At most I had the computer on for weeks (forgot to turn it off after I tried something) and when it woke, it still spun.

Computer info:
Mid 2011 iMac with High Sierra 10.13.6, 16gb RAM, 1tb HDD

Background:
I moved six months ago and when I plugged the computer back in something was off. First it was really slow and then it started acting up, only showing questionmarks in the status bar. In the same time I added another account for my girlfriend (I'm pretty confident the problem had started before that but I'm not entirely sure) and before long the problem was as is still. Note: when moving I had it packed down in the original box so it should've been safe, and I carried it from one apartment to another (just 30 meters or so) so I don't see how it could've been damaged from that.

What I'm able to do: As far as I can see my girlfriends account works without any problems

My research so far: So having googled this for six months now I've A) found people with similar problems (though no (working) solutions), and B) ran out of keywords. Lots of people which describe a similar problem seemed to have it caused by either faulty startup objects or faulty hardware. Since I can't log in, not even in safe mode, I can't disable the startup objects (I tried to log in whilst pressing down the shift-key but that didn't work) and a hardware/hard drive analysis says everything's fine.

What I've tried:

  • Hardware check which came up empty, saying everything was alright
  • HDD scan which came up empty
  • Resetting PRAM/NVRAM and SMC
  • Safe mode which managed to get me inside at first but then froze. Now I can't even log in this way.
  • Login without start objects (login in whilst pressing shift-key)
  • Reinstalling the OS (twice) which did nothing (actually it was after that safe mode stopped working (not that it was really working before))
  • Disconnected all peripherals/tried with another mouse+keyboard (for no reason at all really)
  • Talked with the apple support which amazingly not only gave support for a soon to be 12-year old, but did so for quite some time. They suggested reinstalling the OS, which as mentioned did not work
  • Update: changing the password didn't work

What to do next:
Yes, exactly, what do I do next? Any other possible solutions? Can I reach my files through the other account somehow (the support told me no but surely there must be a way with another admin account and the password?), perhaps through the terminal. or maybe turn off the startup objects from there? Install an earlier OS (mine is the latest for that model)?

Update: This thread describes a very similar problem and points out icloud (at least by one person) as a potential instigator, something I had issues with (couldn't log in/out and it kept telling me to do so for about six months(!)). Anyway, the suggested solution(s) aren't possible in the way that they suggest and as I understand it it's not possible to change the UUID from High Sierra and onwards and it's not possible to log out/change the apple ID from outside an account?

Thanks!

2
  • Does this answer your question? Two login accounts, admin account password unable to login
    – Allan
    Jan 16, 2023 at 13:20
  • I don't think so since typing the wrong password at the login screen doesn't take me beyond that and the problem arise when typing the right password. But it doesn't hurt to try I suppose so I'll do that later (doing an extended hardware test atm for no reason at all really). Thanks for your reply! Jan 16, 2023 at 13:37

1 Answer 1

0

If UserB is an Administrator, then UserB can run an interactive shell as user UserA by entering the command below.

sudo -i -u UserA

If prompted, enter the password for UserB. Once the shell is executing, files for UserA can be moved/copied to the /Users/UserA/Public folder, where UserB can access the files using the Finder application.

1
  • Very good news! In case nothing else comes up I'll do this for sure. Thank you! Jan 16, 2023 at 18:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .