2

The built-in dictionary "New Oxford American Dictionary (English (US))" does not work anymore. Whatever word I type in, "No entries found." is always shown in the Dictionary app.

I also noticed a change in the tab header. It changed from "American English" to "English (US)".

I also tried it while running my MacBook Pro M1 (Ventura 13.1) in safe mode, but the behavior was the same. I have a hunch that the error occurred with the update to Ventura, but I'm not sure about that.

The dictionary shows the same erroneous behavior with a newly created user.

Is there a way to reset the specific dictionary or the dictionary app? Any idea how to fix this?

Screenshot of the Dictionary app

2
  • I noticed some oddness in Dictionary, too. De-selecting and selecting the dictionaries in the app's Settings seemed to fix it.
    – benwiggy
    Jan 12, 2023 at 11:13
  • I tried that too, but to no effect.
    – Axel Meier
    Jan 12, 2023 at 12:36

1 Answer 1

3

Finally I could fix the problem myself by following the steps in this apple discussion.

For completeness I repeat the steps here:

  1. Set preferences in Dictionary.app so that no dictionaries are enabled. (There's always one active, even if you unselect all, so I kept the Apple dictionary, which was the last unselected dictionary.)
  2. Close the app.
  3. Go into recovery mode
    • Press and hold the power button on your Mac until "Loading startup options" appears.
    • Click Options, then click Continue. (See also the Apple intro to macOS Recovery)
  4. Open Terminal, type csrutil disable, and restart computer.
  5. Go to two long folder paths: /System/Library/AssetsV2/com_apple_MobileAsset_DictionaryServices_dictionaryOSX and /System/Library/AssetsV2/PreinstalledAssetsV2/InstallWithOs/com_apple_MobileAsset_DictionaryServices_dictionaryOSX (the second one was already empty for me) and delete everything inside.
  6. Restart Dictionary and set the dictionaries you want, and they will all download from Apple and the files you deleted before are replaced by uncorrupted files!
  7. Empty your trash.
  8. Go back into the recovery mode and run csrutil enable in the Terminal and reboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .