1

I own a Mid 2011 Macbook Air 13". It is running macOS Mojave 10.14.6.

I replaced the battery once with a battery purchased from Amazon.

coconutBattery is reporting, as of right now, as having:

  • Full Charge Capacity: 7121 mAh
  • Design Capacity: 7200 mAh
  • Manufacture Date: 12/12/2016
  • Cycle Count: 68
  • battery status: Good

The problem is that it drains extremely fast. I have tried Ubuntu on it as well, no luck. Even the previous version of macOS on this system (High Sierra). I did a full battery drain, charged to 100% and still no luck.

While turned off, I held down Shift + Control + Option + power button. I held it for about 10+ seconds, I release and the MagSafe LED turned from orange to green for a few seconds, then back to orange.

I thought it was the battery, so I ordered another battery from Amazon. The same issue.

This is making me believe that maybe some kind of connection is bad on the battery, or the Mac is having some strange issue. I know it's an old laptop, but it's been one of my favorites and I carry it around whenever I am in an area where it could be stolen. The replacement battery from iFixit is about $70, but I don't want to deal with it if it's the Mac.

Any ideas what I can try? I remember the battery life was amazing way back when I bought it.

2
  • Is Amazon known for supplying rated OEM components or cheap equivalents?
    – Solar Mike
    Commented Jan 11, 2023 at 6:15
  • Basically the only real other option IMO is the system is actually draining the battery. Have you had a look at the CPU/... resources being used over the last days?
    – X_841
    Commented Jan 11, 2023 at 7:38

1 Answer 1

1

The tell-tale here is that a brand new battery behaves in the same way. Even a cheap 'imitation' Apple battery should work correctly on day 1, at least.

That suggests that it's a hardware problem. You'll need to take it to an Apple Store or other repair shop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .