I'm trying to download a specific episode of 24, that I have previously bought and I keep getting an error message that is completely out of place. I have tried to download many previous purchases and all result in the same error:

enter image description here

However I am on my computer, and I am connected to Wifi. I am able to download new purchases as usual, it is only previous purchases.

How can I get around this error which is blantantly incorrect?

  • I take it you've tried disconnecting/reconnecting your computer from Wi-Fi, and relaunching iTunes? – jtbandes Mar 22 '12 at 23:31
  • Are you connected to a 3G dongle or a WiFi personal hotspot? – Graeme Hutchison Mar 22 '12 at 23:37
  • Yep tried restarting things, still same error. I'm just connected to a normal Wifi network (TimeCapsule is the base station) on a landline ADSL connection – Jonathan. Mar 22 '12 at 23:40
  • Have you tried downloading another app (needs to be over 20mb) perhaps a free one to test if it is the product, store error, or a network error on your side – Graeme Hutchison Mar 22 '12 at 23:46
  • I have tried downloading other things (that I've not bought before) and it works. – Jonathan. Mar 22 '12 at 23:47

You could rule out the possibility of a local problem by attempting to download purchases on another authorised device, and refine the diagnosis by trying it both on and off that same wireless network.

Or you could head straight for iTunes support - when I got corrupted characters in my pre-purchased copy of the Steve Jobs biography last year they had a fix to me within two hours. Based on the Q&A so far I think you're going to need to get Apple to look at your account.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .