4

Years ago, I changed some preference in iTerm2.

Now, when I start iTerm2 there is no open terminal window. I always have to open one with Command N.

I can't figure out the setting again and failed to Google it.

2
  • I think it usually does but now that you mention it it doesn't do it for me right now. Jan 26, 2023 at 13:23
  • @JanGronemann yes, opening it is default behavior. I does on my desktop, but not on my old MBP. But I don't use it that often anymore... Hence, I guess I will just ignore it. :)
    – andreas
    Feb 12, 2023 at 13:47

1 Answer 1

3

In iTerm2's preferences, on the general tab, use the window restoration policy "Use System Window Restoration Setting". Even if you have none set up in your system (the yellow sign appears). This will always open an new window on startup, even if the last state had no open windows.

1
  • 1
    Thanks, this solved it.
    – andreas
    Aug 11, 2023 at 9:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .