11

I keep getting this notification, I don't know if Chrome tries to add those items to "Allow in the Background" setting but it's a bit annoying as I would like to keep Settings notifications.

macOS Ventura 13.1 and I only have Chrome Canary installed.

Screenshot of a macOS notification saying : "Google Updater" added items that can run in the background. You can manage this in Login Items Settings.

5
  • 1
    Any Google product installed uses the Google Updater. it’s similar to Adobe CC Helper that gets installed whether you want it or not.
    – Allan
    Commented Jan 8, 2023 at 23:13
  • @Allan So the only solution if I want to get rid of this notification and keep Chrome Canary installed would be to allow Google Updater to run in the background ?
    – tama
    Commented Jan 8, 2023 at 23:21
  • 2
    Why not get rid of Chrome altogether and get Edge? They use the exact same engine but no Google tracking. But to answer you shoud go into settings to see and allow/disallow what you deem appropriate.
    – Allan
    Commented Jan 8, 2023 at 23:26
  • 1
    I just installed Ventura and turning off notifications in settings does not work. The Notifications settings list shows Google Updater as not allowing notifications, but it does it anyway. Commented Jan 16, 2023 at 22:03
  • 2
    Since you (apparently) want to run something from Google, my approach is not an answer. But my approach was to search and destroy EVERYTHING from Google, and to use /etc/hosts to disable some of their domain names.
    – WGroleau
    Commented Jan 16, 2023 at 22:57

3 Answers 3

20

First of all let me point out that I am using Google Chrome 108 and Mac's newest OS (Ventura) for reference, which are the latest version of both at the time of this posting. Ventura's menus are very different from previous versions of the OS.

I attempted the deletes by majorgear and when I launched Google Chrome again after reboot, 2 items in LaunchAgents were back in that folder and the notices started again. I still needed to edit one of them, so majorgear's posting was a must-read because the files are the right ones to work with.

Please be sure to do all of these steps presented here.

First I removed the Login Item (Google Chrome) via the system settings which kept re-inserting itself.

Listing at: System Settings -> General -> Login Items

I then turned off every Google notification in the notifications system settings and Google Updater ignored my plea and kept doing them anyway. Do still turn these off. Turning them 'on' at any point should basically completely undo what you are attempting here.

Listing at: System Settings -> Notifications

I also unchecked the selection box on the bottom right that shows you user profiles that says to show it every time Chrome starts.

For good measure, I also turned off Google Chrome's 'Syncing' setting inside the browser while I was working on this.

So you don't have to scroll back to that other answer, deleting all google files in these folders was the next important thing:

~/Library/LaunchAgents
/Library/LaunchAgents
/Library/LaunchDaemons

After deleting the google files and rebooting, as mentioned above -- two of the files were back where I deleted them from... (See below.)

Notifications kept happening! (You still need to delete, it just wasn't complete yet at this point.)

I have to use Google Chrome for work so simply using another browser is not an answer, nor ever really a helpful suggestion when it is required of you. I have to test apps in all major browsers, so I already do that.

Then I looked at the files after launching Chrome again to see what was going on.

In the first folder (~/Library/LaunchAgents) these are the two files which keep showing back up:

com.google.keystone.agent.plist
com.google.keystone.xpcservice.plist

In the first one (com.google.keystone.agent.plist) there is a setting that tells it to launch.

In the xml code there is a key set to true:

<key>RunAtLoad</key>
<true/>

So I edited that file and changed the value to false, like so:

<key>RunAtLoad</key>
<false/>

I turned Syncing back on in Google Chrome and rebooted.

Google Chrome is no longer reinserting itself as a login item, and I am not getting any more of those annoying Google Updater notification blurbs.

4
  • 3
    Seems to be working after few reboots, I'll accept the answer, thanks !
    – tama
    Commented Jan 21, 2023 at 15:41
  • 2
    It worked for me. Finally Thank you, thank you! I can feel at peace. I don't understand why Google (or Apple?) doesn't fix this. Commented Mar 10, 2023 at 0:59
  • Interestingly I don't have anything from Google in ~/Library/LaunchAgents. Maybe I removed it all-together before. I don't have anything from Google among my start objects. It seems each time I start Chrome the Goggle Updater starts again though. Just did a force quit and hasn't started up again. Will likely return with Chrome.
    – MiB
    Commented Dec 30, 2023 at 6:05
  • Did you clear all three folders or just the one you mentioned? Assuming Google didn't make any changes, please be sure you followed all of the instructions I gave and also removed everything from all the folders - not just some of the steps in case you didn't. You may be doing everything properly but I have run across people who did not complete every step, and so things didn't work correctly for them. Also, on my own machine I upgraded my OS from Ventura to Sonoma since I posted this and now the latest browser version is Chrome 120 and the issue hasn't returned on my Mac, at least not yet. Commented Dec 31, 2023 at 22:44
1

I was able to fix this with an applescript, this is the repo if you want to try it out:

github.com/abelcha/OSX-Persistent-Notification-Remover

-1

Go to each of these folders and remove files belonging to Google Chrome.

~/Library/LaunchAgents
/Library/LaunchAgents
/Library/LaunchDaemons

Restart your computer.

Verify the issue is resolved and select my response as the correct answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .