I have installed the latest version of Alacritty with the following command:

brew install --cask alacritty --no-quarantine

Then, Alacritty appears in the launcher, but when I click on the icon it seems to start and exit immediately. However, I can launch it successfuly by typing alacritty in the terminal or by typing the full path /Applications/Alacritty.app/Contents/MacOS/alacritty.

I do not even see an error message, so I do not know what to look for.

I have a Macbook Air M1 with MacOS 11.3.1.


Here is the output of the brew command to install alacritty:

==> Downloading https://github.com/alacritty/alacritty/releases/download/v0.11.0/Alacritty-v0.11.0.dmg
Already downloaded: /Users/MY_USERNAME/Library/Caches/Homebrew/downloads/a92d1e0bfe7edda684ff7192829d0b59ac82da6b17dd98959ee9f614052b5d40--Alacritty-v0.11.0.dmg
Warning: macOS's Gatekeeper has been disabled for this Cask
==> Installing Cask alacritty
==> Moving App 'Alacritty.app' to '/Applications/Alacritty.app'
==> Linking Binary 'alacritty' to '/opt/homebrew/bin/alacritty'
==> Linking Binary '_alacritty' to '/opt/homebrew/share/zsh/site-functions/_alacritty'
==> Linking Binary 'alacritty.bash' to '/opt/homebrew/etc/bash_completion.d/alacritty'
==> Linking Binary 'alacritty.fish' to '/opt/homebrew/share/fish/vendor_completions.d/alacritty.fish'
==> Linking Binary 'alacritty-direct' to '/Users/MY_USERNAME/.terminfo/61/alacritty-direct'
==> Linking Binary 'alacritty' to '/Users/MY_USERNAME/.terminfo/61/alacritty'
==> Linking Manpage 'alacritty.1.gz' to '/opt/homebrew/share/man/man1/alacritty.1.gz'
==> Linking Manpage 'alacritty-msg.1.gz' to '/opt/homebrew/share/man/man1/alacritty-msg.1.gz'
🍺  alacritty was successfully installed!
  • Please update your question with the terminal output from the install. Jan 3 at 14:21
  • I would also suggest getting macOS up to date as well. brew's OS support only goes back so far, and Big Sur is the oldest at the time of writing. Jan 3 at 14:26
  • 1
    @AndyGriffiths thanks. Indeed I had an old MacOS version, this is a new laptop and I forgot to upgrade. I just did it, I now have version 13.1. I tried to uninstall and reinstall alacritty and pasted the output in my question. The problem persists. Jan 3 at 15:31
  • Ty. Can you start the app from Spotlight or from the Finder? Jan 3 at 17:59
  • @AndyGriffiths no, I can only start the app from the terminal. Jan 4 at 9:22

1 Answer 1


I eventually found the issue, it was in my alacritty configuration file.

In the file ~/.alacritty.yml, I used to have these lines to launch tmux when alacritty is started:

    program: tmux

This always worked well on my Linux machines as well as when I started alacritty from the terminal on Mac. But I guess that tmux is not in the path when you start an application from the launcher, so I had to write the full path in the config file:

    program: /opt/homebrew/bin/tmux

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .