4

I moved folders on Desktop to consolidate files. But when I double click, it says “File Not Found.” When I try again, the file opens normally.

Desktop/FolderA/Files to Desktop/FolderB/FolderA/Files

Then, when I move FolderA back to the Desktop, the same behavior is exhibited: files don’t open on the first attempt.

This is a brand new Mac with latest OS.

I spoke to Apple support and they asked me to reinstall the OS; still the same issue.

They have captured data etc and told me they will get back in few days.

Does anyone know how to fix this problem?

Edit 1

  1. I download a folder from Dropbox or OneDrive.
  2. The folder downloads as a Zip file in the Download folder but it automatically decompresses it. As expected.
  3. Assume the downloaded folder has 10 files.
  4. I can open the files from Download folder, no issues.
  5. But when I drag and drop the downloaded folder to Desktop, the files don’t open in the first attempt.

Edit 2

I created a new user and followed the above steps in Edit 1. Same problem. Files don't open in 1st attempt.

Edit 3

Screenshot attached.

enter image description here

Edit 4

  1. From the linked OneDrive Folder: copy folderA to Desktop/test/folderA/files
  2. The files open on the first attempt
  3. Move folderA to Desktop. The files do not open on 1st attempt.

This is a bizarre issue.

Edit 5

24 Hours later, Apple support asked me to reset user permissions but still the issue persists.

Edit 6

  1. Download a folder from cloud drive. It downloads as Zip file but does not automatically decompress. (Strange as earlier, it automatically decompressed)
  2. Put the Zip file on Desktop and decompress by double click.
  3. The files open in first click. The folder structure is: Desktop/FolderA/FolderB/FolderC/Files
  4. Copy FolderC to Documents folder by cmnd C, cmnd V. The files from Documents folder open in 1st attempt
  5. Delete FolderC from Documents
  6. Now, drag and drop FolderC to Documents folder. This time, the files do no open in first attempt.

Edit 7

48 hours later, Apple support said to uninstall OneDrive as it is crashing in the background. I did that and still same problem.

11
  • 3
    Are you using “Offline Files?”
    – Allan
    Commented Jan 2, 2023 at 21:12
  • Not sure what that means. But the files get downloaded to Download folder. They open without issue. Problem happens when I drag the downloaded folder to Desktop
    – chintan s
    Commented Jan 3, 2023 at 5:44
  • 2
    Offline files s when you have files synced to OneDrive but they stay in the cloud until you want them. You double click once to download and again to open. The behavior you described sounds like you’re using offline files. Can you open a Finder Window of your desktop folder in list view and post a screen shot?
    – Allan
    Commented Jan 3, 2023 at 7:11
  • I have added two edits, one for a test user and one for screenshot.
    – chintan s
    Commented Jan 3, 2023 at 10:05
  • I can’t reproduce the behavior. What is concerning is that you say the “downloaded file decompresses automatically.” This is not a normal action and quite insecure. You have to double click the zip file to open it and again to access it. Are you using some sort of app to automaticall decompress zip files?
    – Allan
    Commented Jan 3, 2023 at 21:46

2 Answers 2

3
+50

It sounds like some sort of extension/login item/syncing issue to me.

I suggest your next step should be to boot into Safe Mode. The process for doing this depends on whether your Mac has an Intel processor or an Apple chip.

If you're not sure how to boot into Safe Mode, refer to Start up your Mac in safe mode. Once you've booted into Safe Mode, test the same things.

When you've finished testing, just restart your Mac to boot up again normally.

If your Mac works normally while in Safe Mode, this means we have narrowed down the problem to software that's loading when your Mac boots up. If so, it's time to investigate login items, fonts, and kernel extensions. See below.

If your Mac still displays this behaviour during Safe Mode, let me know so we can investigate further.


Investigating login items, fonts, and kernel extensions

Let's start with Login Items:

  1. Startup normally
  2. Go to System Settings > Users & Groups
  3. Select the General icon
  4. Click on Login Items
  5. Now remove all of "Open at Login" items by highlighting them and clicking on the - button below
  6. Restart your computer

Now your Mac will boot up without those login items loading. Test this and see if the problem persists:

  • If the problem goes away you know one (or more) of the Login items were causing the problem. You can then add them back in one by one until you've identified the culprit. Problem solved.
  • If the problem does persist, it's either a problem with fonts you've installed yourself or with a 3rd party kernel extension. A little more info below:

Fonts:- You can remove any of the fonts you've installed yourself to see if this makes a difference.

Kernel Extensions:- You can open Terminal (found within your Utilites folder) and enter the following command:

kextstat | grep -v com.apple

The above command will list 3rd party kernel extensions (you may need to stretch the Terminal window so it's easier to read). Look for anything you don't remember installing, or something that belongs to software you've removed, or just anything that looks out of place. Remember though, this is a list of 3rd party kernel extensions and therefore any of them could be causing the problem.

14
  • Thanks for reply. I had already tried Safe Mode but the problem was still there. As asked by Apple, I reinstalled the OS but that did not solve it either. I looked at login items, there were two: Google Drive and Dropbox. Removed both and still same issue. Now, the Recents folder has become slow. At Startup, it would load the items fast but now it takes 30+seconds.
    – chintan s
    Commented Jan 5, 2023 at 13:39
  • Kernel extensions: output of the command is No variant specified, falling back to release
    – chintan s
    Commented Jan 5, 2023 at 13:52
  • Only thing I have download is: iTerm2, Anaconda, ZSH, Office 365, Google Drive, Dropbox.
    – chintan s
    Commented Jan 5, 2023 at 13:53
  • Prior to this issue, there was a problem with Stage Manager. I had enabled it and it would minimise apps as thumbnails on left side. But when I disabled it, it would still minimise apps as thumbnails. So I called Apple support, and they asked me to use safe Mode. It worked well in Safe Mode and then the issue never occurred.
    – chintan s
    Commented Jan 5, 2023 at 14:18
  • 1
    Well, this is only an issue I've ever seen when related to online storage/syncing service (e.g. using MS One Drive, etc) and certainly not as default macOS behaviour. I also wouldn't accept this and would return it if Apple can't resolve it. While I can't right now think of how this could be related to a bad batch of corrupted macOS pre-installations, that's sort of the only thing that makes sense to me. If it's not resolved I'd be interested to see if another Mac purchased a month down the track displayed the same behaviour. Regardless of the cause, very strange indeed!
    – Monomeeth
    Commented Jan 11, 2023 at 22:15
0

Went to the Apple store and the assistant was able to reproduce the bug, in the machines they have. It seems the bug is in the OS build.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .