I use a MacBook Pro for work and use Microsoft Visio for documentation - since there isn't a native application available, I use Visio through either Google Chrome or Safari.

Lately I've noticed that whenever I right click on an object in Visio, it brings up the grey selection box that typically comes up whenever you're trying to select multiple objects.

But, I'm just trying to click on a line and change it from solid to dotted.

enter image description here

If you pan the mouse toward the context menu that pops up after right clicking on an object, the object that you've selected will be deselected - this seems to happen when the mouse hovers over the canvas.

enter image description here

This makes it almost impossible to use the context menu because whatever you've selected will automatically be deselected once you try to make changes to it (e.g. if you're trying to change a solid line to a dotted line).

But, sometimes you can get to the context menu without having your mouse hover over the canvas, and this prevents the object from being deselected...

enter image description here

It took me nearly 30 minutes to select this edge and change it from solid to dotted - all other attempts have failed, and I don't know much about Visio internals.

Does anyone know what the issue might be?

I've tried:

  • Adjusting my mouse's tracking, scrolling, and double-click speeds
  • Switching web browsers (i.e. Google Chrome and Safari)
  • I can't test whether this uses the same click mechanism as the Mac does natively. On Mac [you can test this on any regular menu] if you click & hold, then drag the cursor down & across items & sub-menus, then if you 'fall off' at any point the sub menu disappears again, if you let go with nothing selected the menu disappears. However if you very quickly tap a menu… it will then stay open until you're ready, & you must click a second time to perform the action.
    – Tetsujin
    Jan 2 at 11:13
  • I'm not sure what you mean - I've tried clicking on the menu really quickly, but whatever I've selected is still deselected no matter how fast I go.
    – bp256r1
    Jan 2 at 11:23
  • Did you compare to the regular menu structure - I told you where to look for simple comparison. If it doesn't work that way, then you'll have to take it up with Microsoft.
    – Tetsujin
    Jan 2 at 11:24
  • Yes, I tried to, but I'm not very good at this - I don't really understand what you meant in your first comment - sorry for the confusion - thanks for your help!
    – bp256r1
    Jan 2 at 11:27
  • Just click any menu item in the menu bar at the top of the screen. Click rapidly, it will stay open, click & hold for more than about half a second, it will close as soon as you let go. [You don't even have to move your mouse after that, just try two clicks, one quick, one held.] Then see if the web app behaves in the same way.
    – Tetsujin
    Jan 2 at 11:29


You must log in to answer this question.

Browse other questions tagged .