9

I have Safari set as my "Browser" in "Default Apps" in Gmail.app's "Settings". When I open a link in Gmail, it opens an internal browser instead of the Safari.app.

How can I configure the links to open in the Safari.app itself where I'm already signed into various services etc?

Gmail.app "Settings" does not have any options related to this. When setting the "Default Apps > Browser" to Chrome, it opens Chrome.app as desired - but I want to use Safari.app.

1 Answer 1

16

Instead of selecting Safari (in Gmail iOS app settings) as your "General > Default Apps > Browser", set "Browser" to "Default browser app".

Now opening links will open the default browser app configured in your iOS settings, and not open the Gmail.app internal browser.

3
  • @NotMe I see it on the latest iOS. I clarified that it's under a "General" heading under the settings. Note that this is in regards to the settings configured in the Gmail iOS app itself, which I've also tried to clarify.
    – JBallin
    Commented Jul 30, 2023 at 22:19
  • I was very wrong. Your answer is good. I was looking in the iphone settings and not in the settings section inside the gmail app. Thanks
    – NotMe
    Commented Aug 3, 2023 at 15:03
  • Thank you! That “default browser app” did not look like it was chooseable!
    – Michael H.
    Commented Feb 11 at 1:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .