1

Any way to disable fn(Globe)-F keyboard shortcut for full screen? Doesn't show up in Preferences->Keys.

enter image description here

3
  • There’s no Fn-F shortcut. Do you mean the “clover” symbol(⌘)?
    – Allan
    Commented Dec 29, 2022 at 1:41
  • There is for me. iTerm2 3.4.15 on M1 Monterey
    – fferen
    Commented Dec 29, 2022 at 2:54
  • I use a 3rd party mechanical keyboard, so I forgot that the new M1s have a globe key. The systemwide command is Ctrl-Cmd-F which makes it curious as to why iTerm woukd remap this. This key combo is coded into the app
    – Allan
    Commented Dec 29, 2022 at 3:08

2 Answers 2

3

With https://gitlab.com/gnachman/iterm2/-/commit/d44f8f16287c420eea54528255e8385e114f4c4f you can use iTerm2 -> Settings -> Keys -> + -> CMD+Enter set to Ignore

0

Open System Settings > Keyboard > Keyboard Shortcuts > App Shortcuts:

  • Application: select "iTerm.app"
  • Menu Title: type "Toggle Full Screen" from the "View" menu
  • Keyboard Shortcut: press another shortcut, e.g. Cmd+Ctrl+F

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .