Last night when I was testing another question I have open here, I was using the AppleTV remote and noticed that it was affecting iTunes running on my laptop. Basically what was happening is that I was trying to navigate through the on-screen menu on the AppleTV, but instead the input was affecting playback in iTunes. Note, though I do have AirPlay enabled, iTunes was not streaming to the AppleTV at the time.

Is this expected behavior, and if so, what must I do to prevent it?

  • Your Mac most likely has an infrared port for exactly this purpose. Jan 28, 2023 at 10:41

1 Answer 1


This is because they both use similar technology. You need to pair the remote with the device you wish to use it on if you have multiple devices.

You can do this on the Apple TV by:

  • going to Settings
  • General
  • Remotes
  • Pair Remote

More info is available in the Setup Guide as well.

If you want to pair it with the Mac, you can do the following steps (From an Apple KB):

  • Log in on your Mac as an Admin user.
  • Get very close to your Mac (about 3 or 4 inches away).
  • Point the remote at the infrared sensor on the front of your Mac.
  • Press and hold the Menu and Next/Fast-forward buttons simultaneously on the remote for 5 seconds.
  • Your Apple Remote is now paired with your computer. You should see a chain-link style lock appear in the center of your screen for a moment.

If you never want the Mac to be controled with the remote, then you can:

  • Go to System Preferences
  • Go to Security
  • Select "Disable remote control infrared receiver"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .