I'm trying to connect my 3rd generation Apple TV to iTunes on Windows 7 via iTunes home sharing, but when I "click" the Computers icon on the Apple TV, it shows an error message stating that it can't connect to my iTunes library. Connecting to the iTunes library on my Mac works. The only thing that doesn't work is using home sharing to get data from my PC iTunes to the Apple TV directly:

Here's what works:

  • Streaming data from my Mac to the Apple TV via home sharing
  • Streaming data from my PC to any device except the Apple TV (Mac iTunes, iPad Music and Videos apps)
  • Streaming data from any device to the Apple TV via AirPlay
  • Remote controlling my PC iTunes via the iPad remote app. I can even tell it to stream the data from my PC to the Apple TV via AirPlay.
  • When remote controlling the Apple TV via the remote app, it shows my PC's

What I've tried:

  • rebooting the Apple TV
  • rebooting the Windows PC, reinstalling iTunes there and checking
  • disabling the firewall on the PC (even with the firewall enabled, all other devices connect to the PC flawlessly)

Any suggestions?

  • Are you running the newest version of iTunes on your PC?
    – jmlumpkin
    Mar 23, 2012 at 0:13
  • Of course I am. I even reinstalled it.
    – MrMage
    Mar 23, 2012 at 8:24
  • Is the PC on the same wireless network as the Apple TV?
    – tlatkovich
    Mar 28, 2012 at 21:47
  • Yes. All the other connections also work.
    – MrMage
    Mar 29, 2012 at 10:45
  • Have you tried disabling Home Sharing on all devices and then turn it on again. I once had a similar issue and I resolved it this way.
    – Shane Hsu
    Feb 26, 2014 at 15:17

2 Answers 2


Might be a long shot, but have you tried disabling IPv6 on your Win 7 pc?

  • Note that disabling IPv6 will disable Windows' Home Group feature.
    – Kroltan
    Dec 25, 2014 at 0:20

Check that the bonjour service is running on the pc.

  • 2
    The iTunes catalog is being accessed by the iPad, so the PC is available.
    – p.campbell
    May 29, 2012 at 20:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .