I am trying to copy a .WPS file from an old floppy disk to my MacBook Pro. I am using a Tendak USB Floppy Disk Drive (https://smile.amazon.com/dp/B01NCV01GY?psc=1&ref=ppx_yo2ov_dt_b_product_details).

The MacBook Pro recognizes the disk and I can see the .WPS file. In Finder, I tried to copy the file into my Downloads folder. It begins copying (I can hear the disk whirring, etc.) and after about 30 seconds (it varies), an error pops up: "The Finder can't complete the operation because some data in "filename.WPS" can't be read or written. (Error code -36)"

I can open the (partially) copied file in TextEdit and I can see portions of the text, but not the complete file. It seems highly variable what, if anything is copied. Sometimes nothing is copied. Sometimes entire paragraphs are copied. Sometimes paragraphs are copied twice or out of order. In addition, it appears that some paragraphs are copied incorrectly into random characters.

Has anyone experienced this before? I guess the problem could be in the floppy disk itself, in the Tendak drive I bought, or in the copy command. If it's in the copy command, is there a way to force the copy to proceed despite any errors it encounters? If it's in the floppy disk or the drive, does anyone have any solutions?

Also, when I try to open the .WPS file on the floppy disk directly into TextEdit, it gives an error and says it can't be opened.

All I want is the text in the .WPS file. The copied file doesn't have to be .WPS.

  • 1
    This is typically a data corruption issue. Try using Terminal instead of Finder’s GUI. Type the command cp /Volumes/NAME OF FLOPPY/file.wps -/Documents. Post your result
    – Allan
    Dec 22, 2022 at 6:25
  • The dread "error -36" is basically saying the file is damaged. It is possible that data recovery software might recover it. And if it is valuable you can send it off to a data recovery company. The only other thing to try would be an old Mac with a built-in floppy drive, that might read the disk properly. Dec 22, 2022 at 16:02
  • @SteveChambers - you might read it off an old Mac … maybe … but then what would you do with it? You'd need to build an AppleTalk<->Ethernet network bridge to be able to do anything other than just write it to another floppy ;))
    – Tetsujin
    Dec 22, 2022 at 17:07
  • Yep, another floppy, formatted on the new USB drive and copied over. I worked at a place that had a LOT of old Macs (Mac-II/IIfx) at one time. The hoops we had to jump through to get files off old floppy disks! While I don't miss it, it did keep the days interesting... Dec 22, 2022 at 18:34
  • Thanks to everyone for the answers and comments. It seems that we need professional help for this. Thankfully, we found a hard copy of the document on the floppy disk, and we decided just to scan that instead of dealing with the floppy disk.
    – Reed Brown
    Dec 24, 2022 at 16:32

1 Answer 1


As the error says, it's struggling to read the disk.
Assuming the floppy hasn't been subject to external magnetic forces over time, then it's equally likely to be a head alignment or substrate shedding issue. The magnetic surface of old floppies can turn over time to either dust, or some very sticky substance that will tear itself off the surface & stick to the drive's read heads… or sometimes both, at different depths.

In the audio world this is known as sticky-shed syndrome where it has received a lot of attention due to the financial & cultural cost of losing some of these valuable old tapes. The same happens with floppies.. though people more often tend to just give up & throw them away, so it hasn't received nearly so much attention & research.

Back in the day it was rare two floppy drives had the same line-up. You could on some occasions traverse half the office trying to find a machine that would read a particularly errant disk… & that's before your current worry of how much the disk is now shedding surface material.

If the data is important, take it to a recovery specialist.
If it's a head alignment issue, it's unlikely any home user will have the necessary equipment… oscilloscope & working tolerances of 0.03mm are not really in DIY territory. If it's substrate, then every time you re-attempt to read it you could be further damaging the surface & also clog the heads, making each attempt less likely to succeed unless you have the tools to clean the heads themselves.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .