I just upgraded my Macbook Pro from Snow Leopard to Lion, and now when I boot into Window 7 using Bootcamp I get the error "Operating System not found."

Following the advice at http://reviews.cnet.com/8301-13727_7-20090187-263/boot-camp-partitions-not-working-after-installing-os-x-lion/, I found that I had MacFUSE installed, so I uninstalled it. The problem still persists.

That article also suggests the possibility that there could be too many partitions on my drive, but Disk Utility says there are only two: Bootcamp and my OSX partition.

I can still access the files on my Windows partition through Finder.

Does anyone know how to fix this problem?

  • 1
    Is it possible for the new version of Lion to have changed bootcamp or your startup procedure in some way? Commented Mar 24, 2012 at 21:36

1 Answer 1


Try to repair the Windows boot sector using the Startup Repair Tool by Microsoft.

You can attempt a Startup Repair using these instructions:

  1. Insert the Windows 7 installation disc or USB flash drive, or a system repair disc, and then shut down your computer.

  2. Restart your computer using the computer's power button.

  3. When prompted, press any key, and then follow the instructions that appear.

  4. On the Install Windows page, or on the System Recovery Options page, choose your language and other preferences, and then click Next.

  5. If you are using the Windows installation disc or USB flash drive, click Repair your computer.

  6. Select the Windows installation you want to repair, and then click Next.

  7. On the System Recovery Options menu, click Startup Repair.

enter image description here

  • I tried this, but when I tried to boot into Windows my computer ejected the disc and I got the same error Operating system not found. If it helps, when I go into Disk Utility in Lion and try to Verify Disk on my Windows partition, I get an error "Invalid Request."
    – Jeffrey
    Commented Mar 24, 2012 at 23:25
  • 3
    Actually, I found the problem. I had the Boot Picker software installed, and the Lion upgrade had made Boot Picker think that Boot Camp was on the wrong partition. Changing the settings so that Boot Picker pointed at the right partition solved the problem.
    – Jeffrey
    Commented Mar 24, 2012 at 23:48
  • @Jeffrey Something related to Boot Picker would have been a second guess. I've read that this tool has caused such problems. Well, I'm glad that you got this problem solved. These are the kind of problems you never want to have ;)
    – gentmatt
    Commented Mar 25, 2012 at 6:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .