2

I have a Brother MFC-2740DW that I have been using for many years. For over a year I have had it connected to the local network via wifi. It has a scanner function, which I normally use via the Printer application on my Mac. Today the scanner function is no longer present.

I found some advice online to reset the print system, which involves deleting the printers in the Printers and Scanners preferences app, then re-adding them back. I tried that, and still there is no scanner function.

When accessing the app, the dialog now looks like this:

enter image description here

This looks different from how it looked previously. But at the top right there appears to be a printer icon and a fax icon, but no scanner icon. Clicking on any of these icons show nothing.

I can access the website built into the printer driver, and for scanning it only shows the option to scan to FTP, which is not what I want.

The printer control panel has a scan option, but when using it and attempting to scan to a file (or any other option) it just says "Check Connection".

The printer still prints normally, which tells me that the wifi connection is working. Rebooting the Mac or power cycling the printer does not help.

I am wondering if this can be fixed.

EDIT:

I temporarily accepted an answer because the scan function appeared to have been restored. The scanner apps looks just like it used to. However, when I tried a scan, I get "Scanner reported an error" and "an error occurred while communicating with the scanner." So I am not out of the woods yet!

Because of those error message decided to reboot the Mac. After that, the scanning is connecting up, and scanning is working.

So again selecting the first answer to come in.

EDIT 2:

I don't scan very often. But over the last couple of years, every time I try to use the scanner function, the scanner icon is dimmed out. Rebooting printer and computer sometimes helps, but usually I have to reinstall the scanner driver, as described in my answer below.

Sometimes the scanner icon is not even present.

Is there some fix other than reinstalling the driver every time?

0

2 Answers 2

1

I'd try new drivers as a first step - https://support.brother.com/g/b/downloadtop.aspx?c=gb&lang=en&prod=mfcl2740dw_us_eu_as

Especially as it mentions this…

enter image description here

After installing the updated Scanner Driver, you will need to use the Mac OS System Preferences --> Printers & Scanners to remove the existing Printer and then re-add it

1
  • 1
    Since this answer came in before I discovered what appears to be essentially the same steps, going to give credit to this answer. Commented Dec 19, 2022 at 19:54
0

I tried lots of things but eventually checked the Brother website before seeing the first answer. Here is the path I took:

  1. https://support.brother.com/g/b/countrytop.aspx?c=us&lang=en
  2. Click "Downloads"
  3. Enter MFC-L2740DW
  4. Select macOS 12.x
  5. Select scanner driver (ICA) 10/28/2021(3.5.1)
  6. Download and install

Reset the printing systems again, and add the printer again. This time when it was installing there was a scan option.

Dragged new printer object to dock.

Scanning is once again available. As noted in the edit to the question, I also needed to again reboot the Mac to get it completely working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .