Seemingly out of thin air my old workshop MBA, a late 2010 with Catalina installed, suddenly stopped connecting to internet through my home router. This happens with devices sometimes, but usually it is fixable, but this is so persistent I am wondering if there is a hardware problem, however unlikely that is.

Basically it won't connect to the internet, but can (intermittently) get a wifi connection. I have multiple other devices including Macs, a PC, tablet and phone devices and all work fine. Even the TV, no problems.

I tried using ethernet: no dice, same thing, I get DHCP IP address but nothing.

The only way I get this laptop on the internet is by connecting to my phone on the cellular network. This works fine but is as slow and expensive as you get.

I have tried reboots, PRAM and SMC resets, creating a new location, resetting Wi-Fi, booting into safe mode, changing the SSID in the router, running Apple Diagnostics, rebooting the router. I can ping other IPs on my home network but nothing outside.

I have a feeling it is a DNS issue because when I try to ping an internet address I get a can't resolve or don't recognise error...sometimes the Wi-Fi is right there but the MBA doesn't 'see' it, other times it does. I have tried my ISP and Google's DNS without any luck.

Next thing is either roll back to an older OS although that shouldn't work, but it is one of the things I haven't done.

Any suggestions? No idea is too small or big.

  • Firstly, welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. Now to your question. I've edited it for clarity and to remove unnecessary information (this helps to focus users on the question rather than get sidetracked). I've also removed 'extra' questions - This site works better when there is only one question per question. That way, it's easier for other people to find solutions if they have the same problem. All the best.
    – Monomeeth
    Dec 19, 2022 at 10:11
  • MBA late 2010 with Catalina installed?? Isn't High Sierra the most recent you can use?
    – lhf
    Dec 19, 2022 at 10:30
  • If you have enough disk space, consider installing High Sierra on a separate APFS volume. It's easy and it doesn't touch the existing installation.
    – lhf
    Dec 19, 2022 at 11:36


You must log in to answer this question.

Browse other questions tagged .