On Monterey (12.6.2), on a heavily-upgraded Mac Pro 4,1, Automator reliably crashes immediately upon startup.

It did this when I was running Catalina, too, but I didn't have a need for it until lately. I only upgraded to Monterey because I wanted to run an app that wouldn't run on Catalina.

I deleted ~/Library/Preferences/com.apple.Automator.* — some five .plist and three .lockfile files — and it still crashes. It re-creates com.apple.Automator.plist when it re-starts (and re-crashes). There are no obvious Automator-related files in /Library/Preferences nor in /System/Library/Preferences.

Yea, this machine is old, and running Monterey is officially not supported. I used the excellent OpenCore Legacy Patcher to install Monterey, and am able to run anything else I try, including many commercial and open-source applications, as well as anything else that came from Apple.

I have another, more modern machine (MacBook Pro 11,5) running Monterey 12.6.2, and it runs Automator just fine. I copied the Automator.app from that machine to my home directory on the problem machine, and it still crashes. codesign -dv on the two apps indicates they are identical.

locate Automator | fgrep -v /Volumes | wc says there are some 46,000 files that have "Automator" in them — I really don't want to dig through that haystack!

I've used up my immediate ideas for troubleshooting this. Any thoughts about how to best get this working? Are there any particular cache files I should try deleting? Thanks!

Here is the stack dump from the crash. locate knows nothing about a file called AMProxyAction.m, which is probably a source file name.

Exception Name: NSInternalInconsistencyException
Description: Invalid parameter not satisfying: cacheDictionary
User Info: {
    NSAssertFile = "AMProxyAction.m";
    NSAssertLine = 146;

0   CoreFoundation                      0x00007ff808d09e9b __exceptionPreprocess + 242
1   libobjc.A.dylib                     0x00007ff808a6be48 objc_exception_throw + 48
2   Foundation                          0x00007ff809aedd03 -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 267
3   Automator                           0x00007ffa26501750 -[AMProxyAction initWithDictionary:] + 275
4   Automator                           0x00007ffa26505fca -[AMAppDefinitionProxyAction initWithGenericActionBundleIdentifier:applicationDefintiion:] + 162
5   Automator                           0x00007ffa2656e5c6 -[AMGenericActionLoader actionsFromTigerApplicationDefinition:] + 673
6   Automator                           0x00007ffa2656e75a -[AMGenericActionLoader actionsFromApplicationDefinition:] + 82
7   Automator                           0x00007ffa264aa496 -[AMApplicationDefinition definedActions] + 75
8   Automator                           0x00007ffa26575691 -[AMActionRegistry loadDefinitionFileActions] + 335
9   Automator                           0x00007ffa264da3cb -[AMLibrary init] + 110
10  Automator                           0x00007ffa264da33c +[AMLibrary sharedLibrary] + 28
11  Foundation                          0x00007ff8099f2fc0 -[NSObject(NSKeyValueCoding) valueForKey:] + 307
12  Foundation                          0x00007ff8099f2c09 -[NSKeyValueNestedProperty object:didAddObservance:recurse:] + 209
13  Foundation                          0x00007ff8099d6fdf -[NSObject(NSKeyValueObserverRegistration) _addObserver:forProperty:options:context:] + 468
14  Foundation                          0x00007ff8099d639f -[NSObject(NSKeyValueObserverRegistration) addObserver:forKeyPath:options:context:] + 118
15  AppKit                              0x00007ff80b697aee -[NSAutounbinder addObserver:forKeyPath:options:context:] + 167
16  AppKit                              0x00007ff80b5e617e -[NSBinder _updateObservingRegistration:] + 542
17  AppKit                              0x00007ff80b5e5281 -[NSBinder establishConnection] + 244
18  AppKit                              0x00007ff80b5de8d9 -[NSObject(NSKeyValueBindingCreation) bind:toObject:withKeyPath:options:] + 760
19  AppKit                              0x00007ff80b5dcbbd -[NSIBObjectData nibInstantiateWithOwner:options:topLevelObjects:] + 1197
20  AppKit                              0x00007ff80b657b54 -[NSNib _instantiateNibWithExternalNameTable:options:] + 656
21  AppKit                              0x00007ff80b6577cf -[NSNib _instantiateWithOwner:options:topLevelObjects:] + 143
22  AppKit                              0x00007ff80b657048 -[NSViewController loadView] + 335
23  Automator                           0x00007ffa265203d8 -[AMLibraryViewController loadView] + 77
24  AppKit                              0x00007ff80b656d99 -[NSViewController _loadViewIfRequired] + 72
25  AppKit                              0x00007ff80b656d16 -[NSViewController view] + 23
26  Automator                           0x000000010218e7a1 -[AMDocumentWindowController windowDidLoad] + 3073
27  AppKit                              0x00007ff80b7bd0aa -[NSWindowController _windowDidLoad] + 548
28  AppKit                              0x00007ff80b7b8c87 -[NSWindowController window] + 110
29  AppKit                              0x00007ff80b8312c6 -[NSWindowController showWindow:] + 36
30  AppKit                              0x00007ff80b7cf2dc -[NSDocument showWindows] + 116
31  AppKit                              0x00007ff80bb5105d __90-[NSDocumentController(NSInternal) _autoreopenDocumentsFromRecords:withCompletionHandler:]_block_invoke.1413 + 92
32  Automator                           0x000000010219ff2f __89-[AMDocumentController reopenDocumentForURL:withContentsOfURL:display:completionHandler:]_block_invoke + 49
33  AppKit                              0x00007ff80bb4dc80 __89-[NSDocumentController reopenDocumentForURL:withContentsOfURL:display:completionHandler:]_block_invoke_2 + 166
34  AppKit                              0x00007ff80bb564fa ___NSMainRunLoopPerformBlockInModes_block_invoke + 25
35  CoreFoundation                      0x00007ff808c8ef00 __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 12
36  CoreFoundation                      0x00007ff808c8edaf __CFRunLoopDoBlocks + 443
37  CoreFoundation                      0x00007ff808c8da42 __CFRunLoopRun + 878
38  CoreFoundation                      0x00007ff808c8d014 CFRunLoopRunSpecific + 562
39  HIToolbox                           0x00007ff811daa5e6 RunCurrentEventLoopInMode + 292
40  HIToolbox                           0x00007ff811daa34a ReceiveNextEventCommon + 594
41  HIToolbox                           0x00007ff811daa0e5 _BlockUntilNextEventMatchingListInModeWithFilter + 70
42  AppKit                              0x00007ff80b5fdfad _DPSNextEvent + 927
43  AppKit                              0x00007ff80b5fc66a -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1394
44  AppKit                              0x00007ff80b5eed19 -[NSApplication run] + 586
45  AppKit                              0x00007ff80b5c2c97 NSApplicationMain + 817
46  dyld                                0x000000010cff952e start + 462
  • 1
    Have you tried running it from a new user account?
    – red_menace
    Dec 15, 2022 at 4:07
  • Good call! I set up a new user, choosing "set up later" for all the options, to keep from complicating things. And Automator started up fine! I'm not exactly sure what to do with this information, though. Suggestions? Dec 15, 2022 at 4:38
  • 1
    That means that the system installation is OK, the problem is with something in your user account. The next step would be to look in your user's library (Automator, Services, Workflows, etc) for items that may be old or damaged.
    – red_menace
    Dec 15, 2022 at 16:29
  • Interesting… ~/Library/Application Support/Automator has a folder in it called "Library Data DON'T USE ". My new user has no ~/Library/Application Support/Automator directory, so I just deleted it… still same symptoms. I'll continue down the list of adjunct directories. Dec 16, 2022 at 22:12
  • Okay, deleting ~/Library/Automator — after making sure my new virgin user didn't have such a directory — worked! If you'd care to write that as an answer, I'll up-vote it and mark it as answered. Thanks! Dec 16, 2022 at 22:18

1 Answer 1


The normal procedure for something like this after an update is to determine if the issue is with the system or with something in your user’s account. Starting up in safe mode and/or creating a new user account should give you a starting point.

If the system works normally in safe mode, look for incompatible extensions, fonts, plugins, launch agents/daemons, etc and remove or update them (note that current OS versions have a sealed read-only system partition, but if SIP has been disabled by a custom installer or a hack, who knows). If everything works from a new account, look for user preferences, login items, etc - things that may have been left over from earlier versions.

For Automator, specific areas to look at would be in the user’s library in Application Support (the Automator folder there is normally used for variables, information about action usage and installation, etc), Automator (items in this folder are third party actions that have been installed by the user - note that Automator will try to load these actions when it starts up), Caches, Preferences, Services, and Workflows. Look for incompatible or out-of-date items; sometimes older workflows will need to be rebuilt to use updated actions. If you don’t care about earlier items just remove or delete them - Automator will recreate files that it uses, such as preferences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .