0

In our office, two of us share HDDs which contain tens of thousands of photos. I like to keep read/write access active but no matter how many times I unlock the Get Info window and check:

Ignore ownership on this volume

it reverts back. In order to move files, etc., I have to go back and check it again. I have multiple drives, not including backups, that all behave the same way.

Is there any way to preserve that setting so that is doesn't change regardless of the computer I use the drive on?

5
  • If it is not saving, the volume is likely not writeable. What partition scheme are you using (FAT, NTFS, HFS, etc.)? If your colleague also uses the drive, it too takes ownership. Basically, you’re conflicting between two users. Also, you might want to consider a NAS for this type of work with the USB drives as backup devices.
    – Allan
    Dec 14, 2022 at 2:33
  • @Allan, The drives are APFS formatted and isn't the point, to make the volume writable and keep it that way? I recognize that NAS would solve the problem, but these drives go on the road a lot making NAS impractical.
    – forrest
    Dec 14, 2022 at 2:41
  • The problem is you must have ownership permissions to modify a file. Your colleague also needs ownership permissions. When you take ownership it will remember thst until your colleague takes ownership until you take it back once again. The setting is working, for both of you and it conflicts. Try a FAT partitioned drive as a test (flash drive is fine) and see if the problem goes away
    – Allan
    Dec 14, 2022 at 3:23
  • Thanks for the explanation.
    – forrest
    Dec 14, 2022 at 3:26
  • Some Googling turned up a file that's responsible for keeping this info. Advice seems to be to delete it & let it rebuild. See apple.stackexchange.com/questions/53215/… and automatica.com.au/2021/09/…
    – Tetsujin
    Dec 14, 2022 at 7:15

0

You must log in to answer this question.

Browse other questions tagged .