1

I recently got a new scanner (Epson RR-600W) that claims compatibility with Image Capture on macOS 13, but when I look at its binary, it has only Intel architectures:

$ file /Library/Image\ Capture/Devices/EPSON\ Scanner.app/Contents/MacOS/EPSON\ Scanner 
/Library/Image Capture/Devices/EPSON Scanner.app/Contents/MacOS/EPSON Scanner: Mach-O universal binary with 2 architectures: [x86_64:Mach-O 64-bit executable x86_64] [i386:
- Mach-O executable i386]
/Library/Image Capture/Devices/EPSON Scanner.app/Contents/MacOS/EPSON Scanner (for architecture x86_64):    Mach-O 64-bit executable x86_64
/Library/Image Capture/Devices/EPSON Scanner.app/Contents/MacOS/EPSON Scanner (for architecture i386):  Mach-O executable i386

I'm pretty sure kernel extensions must be arm64, but I don't know if Image Capture drivers are kernel extensions.

5
  • Is this a theoretical question or did you actually try to use the scanner and it didn’t work? If you haven’t tried yet: what happens if you do?
    – nohillside
    Dec 11, 2022 at 12:47
  • @nohillside Yeah, I've tried it, and it's not working (that is, it doesn't show up in Image Capture.app; it does show up as a USB device). I emailed their support about it, and at 4 pm on Friday they responded saying I'd have to call to get an answer. Guess what time their support line closes?
    – Rick
    Dec 12, 2022 at 1:43
  • 1
    Uhh, tough luck. Anyway, if the support can‘t help you, please ask a specific question related to the problem.
    – nohillside
    Dec 12, 2022 at 7:03
  • What scanner model is it?
    – benwiggy
    Dec 12, 2022 at 10:07
  • @benwiggy Updated the post. It's an Epson RR-600W.
    – Rick
    Dec 13, 2022 at 4:12

2 Answers 2

3

I also have an EPSON scanner (Perfection 4990 Photo), and Image Capture works fine using the /Library/Image Capture/Devices/EPSON Scanner.app driver, even though it's an Intel process on an M1 Mac.

The Image Capture app itself still runs natively.

The latest version (as of December 2022) of the ICA driver is 5.8.12, and is available here: https://ftp.epson.com/drivers/ESICA_5.8.12.dmg

Epson Support have told me in an email that they have 'no plans' to update the driver for Apple Silicon. (There are 579 scanner models listed in 'DeviceInfo.plist' in the driver's bundle....!!! However, the RR-600W is not in the list.)

Epson does have its own scanning software, independent of Apple's Image Capture, of course.

6
  • That's good to know, but I'm interested in using the Image Capture driver, not their app.
    – Rick
    Dec 12, 2022 at 1:42
  • 1
    @Rick I'm talking about exactly the same component that you show in your question. The EPSON Scanner.app is in /Library/Image Capture/Devices, and is the driver that Image Capture uses.
    – benwiggy
    Dec 12, 2022 at 7:45
  • Ah so you are! I'm sorry, I misread. I have 5.8.12 installed. I only installed their "ICA Scanner Driver v5.8.12 for Image Capture," rather than the "Combo Package Installer." I hope that's not the reason it's not working for me, I hate to install all their other crap.
    – Rick
    Dec 13, 2022 at 3:08
  • Did you have any documentation from Epson about using their scanner with Image Capture? I can't find any.
    – Rick
    Dec 13, 2022 at 3:10
  • 1
    @Rick Try their support, but Epson are pretty hopeless. Their drivers are Universal Binary -- 32bit and 64bit Intel!!!!! I keep asking about ARM versions, but they have 'no release date'. It's really annoying how they make each installer of Epson Scan 2 specific to each model; even though the device-specific bit is a separate file. I'm loathe to subscribe for VueScan. You'd think it would all be standard protocols that don't need specific drivers. (Rant over.)
    – benwiggy
    Dec 13, 2022 at 9:27
1

The Image Capture drivers are regular executables - they're not kernel extensions. So in theory (and most probably practice as well) they should work just fine under Rosetta 2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .