Half a year ago, I got an old Macbook Pro from my dad. I had set up dual boot with Debian. I haven't used the laptop for several months. Now suddenly it didn't want to boot the Debian partition, so I wanted to redo the whole dual boot. Erased the Debian partition and tried to merge it with the main macOS partition. Unsuccessfully. I went for a restart and since then I'm also unable to boot the macOS part. Only recovery mode or live USBs.

So far I'm no super savvy linux power user, but can manage a bit of complexity so I immediately dove into debugging. Found this series of threads. Went down through all the steps. Disk seems fine now (at least the disk util said so), but Macbook is still unbootable.

Does anyone have any idea what to try out next? My only goal is to extract the data from the macOS partition. Of course willing to disclose any further information upon requests (I'm not sure what would be helpful at this point).

Another post I made before being aware of this part of SE.

  • Was your first step when the mac was bootable to make a full backup?
    – Solar Mike
    Dec 10, 2022 at 12:45
  • I have partial backup, most of the important data is safe, but I'd like to debug this to find out what happened... so no, there unfortunately isn't an option of rolling back to some time machine backup
    – maklmor
    Dec 10, 2022 at 12:48
  • Search on here and read carefully q&a like this one: apple.stackexchange.com/q/262457/237687
    – Solar Mike
    Dec 10, 2022 at 13:10
  • thanks for the tip, but this one wasn’t really useful, as I had already tried all the step mentioned there
    – maklmor
    Dec 11, 2022 at 7:17
  • That was just one as an example, check the others.
    – Solar Mike
    Dec 11, 2022 at 7:19


You must log in to answer this question.

Browse other questions tagged .