3

I am unable to mount my segate external SSD. Everytime I restart macbook pro, I dont see volumes from my external SSD. If I try to mount manually from Disk utility, I get below error.

Could not mount “Volume1”. (com.apple.DiskManagement.disenter error -119930872.

Strange thing is, If I logout and log back in then all volumes are being mounted properly. But it does not work after restart.

Things I have tried until now are as below.

  1. Problem started after I migrated from Monetory to catelina. It was working fine on Monetory mac OS.

  2. SSD works fine when I tried on another laptop with mac OS 10.13(I believe, dont remember exact version)

  3. Erased disk using Mac Disk Utility, command line, Windows diskpart as well as ran dd to clear first sector. I have also tried erasing disk with options like ExFat, APFS, MSDOS and JHFS but everytime I erase, i get below error after erase.

    Could not mount disk2s1 after erase I am not sure if disk has any issue as it works fine if i logout and log back in. I am looking to use this external drive to install WindowsToGo to boot on Mac OS with one additional ExFAT drive to use between both Windows and Mac.

Any help is appreciated.

Thanks.

Update: Output of diskutil command is as below. Current state of disk2 is after tried all other partition options.

    /dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         500.0 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +500.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume APPLESSD - Data         177.1 GB   disk1s1
   2:                APFS Volume Preboot                 1.9 GB     disk1s2
   3:                APFS Volume Recovery                1.1 GB     disk1s3
   4:                APFS Volume VM                      20.5 KB    disk1s4
   5:                APFS Volume Macintosh HD            8.8 GB     disk1s5
   6:              APFS Snapshot com.apple.os.update-... 8.8 GB     disk1s5s1

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *500.1 GB   disk2
   1:                 DOS_FAT_32 M                       500.1 GB   disk2s1

If I logout and log in and do Get Info for volume then I see below

7
  • Re 1: For some formats and some macOS versions an older macOS (Catalina) may have problems with a disk formatted under a newer macOS (Monterey). Erase and format the whole SSD (Disk Utility) on the oldest macOS you will be using.
    – Gilby
    Commented Dec 7, 2022 at 2:15
  • To help diagnose the current state of your disks, please add the output from the Terminal command diskutil list.
    – Gilby
    Commented Dec 7, 2022 at 2:17
  • @Gilby In fact I tried that as well. erased on older version of mac but still result is same. Please see updated question with output of requested command. Commented Dec 7, 2022 at 18:13
  • If you logout/in so that the drive mounts and you Get Info on it in the Finder, is there an option at the bottom of the Get Info window that says "Ignore ownership on this volume"? If so, is it enabled? If not, try enabling it and see if that helps.
    – pion
    Commented Dec 13, 2022 at 9:55
  • @pion No. I dont see that option. Updated qustion with get info image Commented Dec 14, 2022 at 18:45

3 Answers 3

2

I ran into this issue and I think I found the main issue: macOS 13 does not like Master Boot Record formatted drives. We were able to consistently repeat this issue when the drives used the Master Boot Record.

When "erasing" the drive, make sure you are erasing at the device level, rather than the volume level. This will allow you to select the format schema and set it to GUID, which should fix this mounting issue.

1
  • 1
    I was unable to format as well on mac. I connected my SSD to windows machine and reformatted with GUID parition map. it works fine on windows but its again same issue on mac. can you please help me with your steps? how exactly did you erase with all commands? Commented Mar 16, 2023 at 18:39
1

I ran into the same problem of MBR-formatted drives not being readable. However, I got macOS to recognize the disk with this error message:

macOS Disk Warning: Disk not readable

I clicked "Initialize..." to init the disk (but not mount it) and then used the diskutil command line interface to erase the disk and create a GUID format:

diskutil partitionDisk /dev/disk4 GPT APFS SSD 10g

Where /dev/disk4 is the disk identifier (see diskutil list), GPT is the GUID partition format, APFS is the desired filesystem format, SSD is the new name of the format, and 10g is the volume size. Afterwards, I was able to use the normal Disk Utility application for further formatting and partitioning.

1

I had this exact problem and it was because my Mac is owned by my company who has a policy against plugging in External USB storage devices. To see if this is your problem:

  1. Open up "System Settings".
  2. Go to "Privacy and Security" on the left.
  3. Scroll all the way down and click on "Profiles" near the end.

If you see something like, "Block USB Storage Devices" then you need to go talk to some IT person to get an exception.

Picture of Profile Settings

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .