I was using macbook with osx maverick and had library in Music.app (~/Music). I replaced this laptop with new one on M1 and did fresh Ventura install on it.

Everything is good except my music library: even after doing rm -rf ~/Music and copying this directory from TimeMachine backup doesn't work, Music.app still can't find all my music playlists even if i use Open menu (cmd+o).

How can i restore it? Did i miss any hidden directory or something like this?

Btw, i have an iPhone that was synced with old system and has all orzanised as needed. Maybe, it can help? Can i import from iphone to mac?

  • 1
    If it is a Time Machine backup is there a reason you are not just using Time Machine to restore your old music library? Nov 29, 2022 at 17:21
  • @SteveChambers, i already restored ~/Music directory from TM backup to new system. But music app didn't see it and says everything is empty. That's why i posted here.
    – trogwar
    Nov 29, 2022 at 17:50
  • and you have done this? support.apple.com/guide/music/… Nov 29, 2022 at 21:00
  • Did you restore ~/Music/Music Library.musiclibrary
    – mmmmmm
    Nov 29, 2022 at 21:58
  • @mmmmmm, no, it doesn't exists because they have different database format now.
    – trogwar
    Nov 30, 2022 at 5:20

1 Answer 1


Okay, found this solution and it's pretty simple.

At first, using "Open" and "Import" options from menu as suggested in Apple support website didn't worked. Copy whole ~/Music directory from TimeMachine backup didn't worked too – still empty Music app.

Found out, that i need to quit Music.app, then hold "option" key and click on app to open it. In dialog box "Choose library" and navigate to ITL file (warn: not XML!). It asked for a library name – need to give different that was in backup files.

It took some time to organise files but finally i have all playlists that was before.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .