2

A collegue of mine upgraded to macOS Ventura, since then the parameter --dry-run is not available for the patch command anymore and our tools do not work automatically anymore as the command prompts for user input.

The version of patch is 2.0-12u11-Apple on Ventura while being 2.5.8 on Monterey.

Is there a known way of how to solve this (for example an upgrade for the patch binary)?

See also

1
  • 1
    Interesting. According to the man page, -C, --check, --dry-run is supported; according to patch -h it isn't.
    – nohillside
    Nov 28, 2022 at 9:26

1 Answer 1

3

brew install gpatch or sudo port install gpatch installs version 2.7.6 for which the --dry-run option is available again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .