I am running Ventura on a MacBook Pro.

So last month my dad passed away and I'm trying to figure out how to turn on FileVault on the machine. Before he passed away, he apparently set my username as the admin and removed him user name as the admin. I found the password for my account in his stuff where he had written it down. But for some strange reason he didn't write down the password to his account. So there are two accounts.

When I go to Settings > Privacy and Security, click turn on FireVault, and enter my password, it doesn't turn it on. So I look at this. I run through the directions, but when I try to reset my password in recovery mode, it says

Authentication server could not be contacted.

Next, I tried to see if I could at least login to his account to disable the SecureToken for his account and enable it for my account. Or I could delete his account (his stuff is backed up).

So, I try sudo passwd <his username> I need to enter his old password, which unfortunately, I have no way of getting.

I go to Settings again to delete the account and I can't do it from Settings.

I try to run the delete command on terminal using dscl

But I run into a DS Error: -14120 (eDSPermissionError) and from subsequent research see how the SecureToken issue might be affecting admin's ability to delete nonadmin accounts. I still need his password.

I try to reset his password again in recovery mode by running resetpassword but I encountered the same error that I came across when running resetFileVaultpassword

Next, I try cracking the password using the directions found here, but I get the following error

defaults[1365:10586] The domain/default pair of (/var/db/dslocal/nodes/Default/users/user.plist, ShadowHashData) does not exist : Property List error: Cannot parse a NULL or zero-length data / JSON error: Unable to parse empty data

when I enter sudo defaults read /var/db/dslocal/nodes/Default/users/user.plist ShadowHashData|tr -dc 0-9a-f|xxd -r -p|plutil -convert xml1 - -o ~/Desktop/tempuser.plist

At this point, I am not sure what to do.


You must log in to answer this question.

Browse other questions tagged .