Normally, on my Mac, when I get an IM via Telegram or Whatsapp, I get a bell-style sound notification.

However, sometimes my Mac will actually read out the message to me in my AirPods.

It was happening with Telegram, and just now for the first time, it started happening with WhatsApp. This happened to be directly after I had finished taking a phone call through my AirPods.

I also have an iPhone, and it's not clear to me whether it was my iPhone reading the message to me or my Mac, since they're both connected to my AirPods.

Please can anyone suggest where I should look for a setting for this? I'm on the latest Ventura 13.0.1. This seems to happen only sometimes, and I'm not sure what's triggering it.

1 Answer 1


Your iPhone was reading the message to you through your AirPods. You can toggle this in Settings → Notifications → Announce Notifications for a particular app's notifications or globally.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .