0

I run an old dinosaur; a late 2013 15" MacBook Pro (i7, quad core, 16GB RAM--soon to be retired) with Big Sur (11.7.7). Big Sur is unfortunately the most "recent" operating system supported by Apple for hardware this old. I'm upgrading in February.

As the subject indicates, the issue has to do with PDF files now showing their respective thumbnails, but only in Finder windows. Of note, earlier today, this was also true for PDF files on the Desktop (when looking at the Desktop itself). I was able to get these to reappear by following these instructions for killing com.apple.quicklook.ThumbnailsAgent within the Activity Monitor, then force-quitting (restarting) Finder. That process restored the thumbnails on the Desktop, but not PDF files viewed within Finder windows.

Finder does however render thumbnails for all other file types without issue. Only PDF's are affected.

Any suggestions for how to fix this annoyance would be most welcomed.

..and thank you in advance!

Update 202211211230: result of qlmanage -m | grep pdf as follows:

enter image description here

5
  • Can you QuickLook PDFs correctly? (Press space to get preview.) Have you set the View Options to include Icon Previews in Finder 's View menu > View Options?
    – benwiggy
    Nov 21, 2022 at 12:33
  • Yes, QuickLook itself works correctly, but the QuickLook icon is also missing from the menu bar in Finder windows--which is very unusual also. I can only trigger QL from CMD-Y, but it previews PDFs correctly, yes. Today, I backed up my hard drive, then took the drastic step of booting into Recovery and re-installing Big Sur. Result: more of the same. Absolutely nothing has changed.
    – Ryan
    Nov 21, 2022 at 16:00
  • Reinstalling is rarely a fix for anything. Quick Look isn't in the default toolbar for Finder. Did you check the View Options? Can you test the behaviour in a brand new user account? (This is a test, to see if it's a problem in your original user account that can be fixed there.) Finally, add the output from this Terminal command to your question: qlmanage -m | grep pdf
    – benwiggy
    Nov 21, 2022 at 16:43
  • GREAT idea testing this on a new user account. (Why didn't I think of this?!). Tried that, same result w/ PDF thumbnails not rendering. On another note, indeed you hit the nail on the head w/ QuickLook icon. It was gone only because I tried at least a half dozen things before posting about this. Some involved terminal commands while searching for a solution. One of these operations reverted the toolbar to its default. Simple fix by simply re-adding the icon.
    – Ryan
    Nov 21, 2022 at 17:39
  • @benwiggy but PDF thumbnail issue still persists.
    – Ryan
    Nov 22, 2022 at 1:42

1 Answer 1

0

You have determined that is not a user-related problem (by testing another user account). In that case, it must be at the system level. You have also reinstalled the OS.

I would have a look to see what third-party software you have installed that might be causing problems. Anything that 'alters' the OS with additional functionality; any Finder extensions; or things like that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .