7

I have an ethernet cable connected to my computer through a USB-C to Ethernet adapter. I want to share the internet from my Mac to my iPhone through Internet Sharing option available through the following path on MacOS: -

System Settings -> General -> Sharing -> Internet Connection.

Channel 48 and WPA2/WPA3 Personal Security level are being used as configuration.

Now while on Ventura 13.0, after enabling the Internet Sharing, The Wi-fi would turn on and then my Mac would act as a router for my iPhone to get connected to the internet and was working as intended.

After Upgrading to macOS Ventura 13.0.1, whenever I turn on Internet Sharing, the Mac refuses to act as a router and does not give out any signals. The Wi-fi is in a blank state. Please help in fixing this issue.

I have tried various methods in order to solve the problem like restarting the computer, changing the configurations etc. however nothing has worked till now.

Below is a picture for your reference: -

Internet Sharing

3
  • 3
    Have you tried it with Ventura 13.1?
    – benwiggy
    Dec 16, 2022 at 15:46
  • @benwiggy Yes after updating to Ventura 13.1, it has started working. However now my iPhone is not able to get connected to the Mac's Wifi. I wonder why that is? Dec 16, 2022 at 16:55
  • The problem might be coming from the fact you have 2 ( at least ) network interfaces named "USB 10/100/1000 LAN". I don't see anyway for InternetSharing to choose the correct real physical interface. Do you know where these name collisions are coming from? [new line] I also noticed that you have up to 8 ( en0..en7 ) Ethernet interfaces. Is this true or already the sign of a serious problem at the network interfaces level? [new line] If you provided the output of ifconfig -a this might help to help you.
    – dan
    Jul 30, 2023 at 17:35

1 Answer 1

3

I had the same issue. I own a MBP M1 and two iPhone (SE 2016 and 12pro). I use the internet sharing while at my office.

I solved it out like this:

  • disable AirDrop (either in System Settings or in the Finder, setting it to "discoverable by none")
  • disable WIFI and disable Internet Sharing
  • enable Internet Sharing (it'll ask if you want to activate WI-FI, approve of it)

BOOM!

Disabling the WIFI and Internet Sharing might not be needed but I thought it'd provide a better "blanker" state for the system.

Hope it helps.

3
  • Hello @Luca Ciminelli. Thank you for your input. My issue got solved after updating to Ventura 13.1, but now the problem is my iPhone is not able to get connected to the Mac's Wifi. I wonder why that is? Do you have any recommendations for that problem? When your internet sharing is working but your iPhone is not able to get connected to Mac's Wifi? Dec 16, 2022 at 16:59
  • I was trying to share my MBP M1's wifi Internet connection with a Windows machine using a RJ45 adapter. The Windows machine would connect and get an IP address and all, but no communication would get through. Disabling wifi and Internet sharing, and then re-enabling Internet sharing (and also wifi in the process) did solve the problem. Thanks!
    – Krachtwerk
    Jan 14, 2023 at 19:10
  • I am facing a similar issue on macos ventura 13.4, after a reboot of the macbook it stops working again.
    – Aravind
    May 30, 2023 at 23:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .