I just upgraded to macOS Ventura and now the Preview.app doesn't seem to have a Print Quality option or a Color vs Black & White option when I'm printing from Preview.

The only weird thing I notice in the Print dialog (shown below) is that it says my HP OfficeJet is using a Laser Printer driver.

I've tried removing and reinstalling the printer a couple of times and it ends up the same way each time.

Mac Studio 2022, Ventura 13.0.1 HP OfficeJet Pro 9020 Series

screenshot of print dialog from Preview.app

The file I'm trying to print is inherently black and white, so I thought that might be part of the problem. So I opened a color image in Preview.app and tried to print it. It turns it into black and white in the print preview and doesn't offer me the Quality or Color vs Black/White either:

screenshot of preview with color image

screenshot of print dialog showing the color image in black/white

Any idea where it is or why the Print Quality and Color/Black&White might be missing?

  • Yes, looks like you're using generic PCL mono print drivers. When you add the printer, make sure that you specify the correct print drivers.
    – benwiggy
    Nov 18, 2022 at 17:53
  • @benwiggy How? When I add the printer it picks all of that stuff automatically. It doesn't give me an option. Nov 18, 2022 at 19:15
  • Ok, I removed and re-added the printer about 6 more times and finally on the 6th time it finally said the drivers were 9020. I have no idea what they screwed up in Ventura. :( Nov 18, 2022 at 19:36
  • Even if Preview.app is among the lousiest PDF viewers out there, this looks more like an issue with the printer driver.
    – Max Wyss
    Nov 19, 2022 at 7:51
  • I have the same problem. Feb 10, 2023 at 20:06

1 Answer 1


Go to Settings on Mac, head over to Printers and Scanners and ‘remove’ the printer you just added. Now ‘Add a New Printer..’ and select the same new printer from the list and add it back. That’s it. You should be able to see things in colour and will preview and print in colour.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .