1

I accidentally formatted the SSD part of an APFS-formatted Fusion Drive during an SSD upgrade. Well, not accidentally, I did it on purpose wrongfully thinking that the Apple SSD wouldn't be needed anymore.

The original hard drive is untouched and raw cloned to another drive for safety. I pulled out the Apple SSD and bought a PCI-e adapter (I mainly use Windows). I've got access to the iMac I pulled the drives from and it boots to a freshly-installed Ventura install in a SATA SSD drive.

All of this is because a customer wanted to upgrade their iMac to an SSD. At the time I wasn't aware how Fusion Drives worked, so here's what I did:

  1. I plugged in the SSD from inside Ventura and cloned the contents using Carbon Copy Cloner, with a SATA-to-USB adapter.
  2. I replaced the Apple HDD inside with the freshly-cloned SSD, but it wouldn't boot. I checked CCC's documentation and read that I could do a fresh install and then perform a Migration Assistant.
  3. I booted into Internet Recovery, Disk Utilities, and formatted both the new SSD drive and the Apple SSD drive part of the Fusion Drive, thinking it wouldn't be needed anymore. I reinstalled Ventura from scratch successfully. No other data has been written to the Apple SSD.

Here's what I tried to recover the data so far:

  1. Tested several data recovery utilities, like UFS Explorer, Disk Drill and R-Studio to no avail.
  2. With the aforementioned Apple SSD to PCI-e adapter, connect both the old SATA HDD and the Apple SSD and mount them in R-Studio. No partitions were found.
  3. I replaced the UUID from the formatted Apple SSD to match the one R-Studio found. (The HDD's UUID minus one) Also to no avail.

My idea was to find the correct structure of a working Fusion Drive APFS set and replace the partition IDs in the partition table of the SSD with the correct ones, so maybe that way I can access the data.

I'm aware this is either difficult or near-impossible to fix, so please share your tips and ideas. Thank you.

5
  • 1
    A detached SSD from a Fusion drive shouldn't impact the HD's readability at all. The 'fusion' part is just a fast cache. What happens if you just put the HD in a regular external USB enclosure & connect it to the Mac?
    – Tetsujin
    Nov 10, 2022 at 12:45
  • 2
    @Tetsujin No: When one part of the Fusion drive is no longer 'present', the entire thing is unreadable. The SSD is not a cache: it contains data not present on the HDD. One file might be split across both drives, at the block level.
    – benwiggy
    Nov 10, 2022 at 13:59
  • Can you explain "No. 1" a bit more? Do you have a clone of the original 'fused' SSD? Can you restore that and put both original drives back?
    – benwiggy
    Nov 10, 2022 at 14:33
  • @benwiggy Ah. My bad - I now see… which makes this a duplicate of apple.stackexchange.com/questions/75680/… & bad news, by the looks of it. [I'll leave my original comment in situ, so we have the 'chain of misunderstanding']
    – Tetsujin
    Nov 10, 2022 at 14:34
  • I was hoping that, since I never zero-filled the Apple SSD, I could overwrite its partition table with one from a working Fusion Drive, and since the blocks would be intact, hopefully that would magically restore the drive. Guess it doesn't work that way. Nov 10, 2022 at 15:42

2 Answers 2

1

A Fusion Drive is one logical volume that spans two separate devices. (The size of the volume is the sum of both parts.)

The SSD is not a cache that duplicates data from the HDD: CoreStorage moves the most frequently used file blocks to the SSD.

Even if you could get the HDD recognised and mounted by itself, you would be left with missing files (and even incomplete files).

You say you cloned the original SSD (I think). Can you restore that clone, and put the original drives back?

It's possible that some data recovery firm could reconstruct the data from both drives, but this is likely to be expensive.

Sorry.

Does the customer not have a backup? Most repair shops make the customer sign a waiver that their data may be lost.

What happens when you remove (or lose) the SSD from a Fusion Drive?

1
  • No, I never cloned the Apple SSD. I (Carbon Copy) cloned the whole OS into an SSD from inside the then-working OS, as I've done several times before. Oh well, I will tell the customer their data's gone. Fortunately every customer signs a waiver, I just feel bad about losing other people's data. Nov 10, 2022 at 15:38
0

Unfortunately, I have to say you are out of luck. As @benwiggy stated in a comment below, if you do not have a, say, Time Machine backup, the data you have on your HD and its backup are unreadable and useless. Therefore, never, never do a carbon copy of an HD of a fusion drive. You need to back up both the SSD and the HD. If one of those is missing, you will lose all your data. The reason behind it is that, apparently, Apple Fusion Drive copies the most used blocks (and not files) to the faster SSD. Because it uses blocks and not files, data recovery is virtually impossible without both drives.

Next time, please do a Time Machine backup before messing up with a fusion drive. I'm sorry, but this is the reality.

If you don't trust what I say here, just go to the experts and what @benwiggy explained about file fragmentation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .