17

In MacOS 13.0 (and 13.0.1) when I paste a link into an email using Mail, it converts the URL into a preview of the web site. How do I turn that off and just have plain links by default? I just want to see the URL I pasted.

Previous version of MacOS did not have this behaviour.

Threads

3
  • Have you tried looking through Mail's preferences?
    – Dillon
    Commented Nov 10, 2022 at 2:30
  • Have you tried pasting with Shift-Command-V (paste as quotation)?
    – jaume
    Commented Nov 10, 2022 at 7:57
  • 1
    …or cmd/shift/opt/v [paste & match style]?
    – Tetsujin
    Commented Nov 10, 2022 at 8:38

8 Answers 8

20

Save this plist as /Library/Preferences/FeatureFlags/Domain/Mail.plist and reboot:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>RichLinks</key>
    <dict>
        <key>Enabled</key>
        <false/>
    </dict>
</dict>
</plist>

How did I find this? I used Hopper on Mail to find likely strings, then worked backwards to find where they were referenced by the code, and then found out that Mail calls _os_feature_enabled_impl("Mail", "RichLinks") to control the feature.

4
  • 1
    it worked! thanks so much!
    – Steve
    Commented Apr 2, 2023 at 20:53
  • 1
    Wow, thanks so much for sharing--finally a way to disable this behaviour altogether!
    – dlehman
    Commented Apr 2, 2023 at 22:17
  • 6
    Here's a Terminal.app command that does the same: sudo defaults write /Library/Preferences/FeatureFlags/Domain/Mail.plist RichLinks -dict-add Enabled -bool NO ; sudo chmod -R o+rX /Library/Preferences/FeatureFlags Commented Apr 11, 2023 at 18:07
  • 1
    See also the solution by @Nate below: MacOS 14.0 now exposes this as a setting Mail -> Settings… -> Composing -> Add link previews
    – Steve
    Commented Oct 8, 2023 at 4:27
6

It's worth noting that this has changed in 14.0 (yes, I know the OP is asking about 13). The defaults write trick no longer works, but! There's now a setting. Uncheck:

Mail -> Settings… -> Composing -> Add link previews

1
  • Thank you to everyone in who posted solutions here, but especially @Nate. The link preview setting exists in iOS 17 also, so hooray. Commented Oct 17, 2023 at 2:46
5

The fastest way to paste a link without it being converted to a preview is via Edit -> Add Link (CmdK). This opens a small dialog box, you paste your link, then hit the OK button.

With the keyboard you use the sequence CmdK CmdV, Return. It’s much faster than pasting (CmdV) into Mail, waiting for it to convert the link to a preview, grabbing the mouse, search the small popup handle, clicking once to open the popup, etc.

Just type CmdK CmdV Return.

4

I also discovered that if you type a space and then paste the URL, it seems to not trigger the Link Preview creation. Then you can delete the space (or leave it). Still annoying, but slightly quicker (maybe?) than K.

1
  • Yes! I've been doing that for a while. Remembering to put the space in though... aagh. Gets me every time. Call with Apple tomorrow to see if they have a better solution. Will update if they are helpful.
    – Steve
    Commented Feb 15, 2023 at 21:34
1

Simply pass your mouse over preview, and a little arrow appear.
Click this arrow to display dropdown menu.
Select Convert to simple link (I'm not sure exact translate match)

enter image description here

The only other way I found to directly past as link is to set Message format to Plain Text in Composing preferences… but inevitably you lose mail formatting

2
  • 4
    Thanks. Yeah I didn't want to go back to plain text. I was hoping there was a config setting somewhere to disable it (since it is just new in the latest version)
    – Steve
    Commented Nov 11, 2022 at 3:18
  • 1
    @Steve I dig into Mail bin and didn’t find any hidden pref. I point out RichLink but it does nothing.
    – Bil
    Commented Nov 12, 2022 at 12:25
0

The plist answer does not seem to correspond to 13.3: I have this:

<key>RichLinks</key>
<dict>
    <key>DevelopmentPhase</key>
    <string>FeatureComplete</string>
</dict>

and have no permission to change it. Nor is it clear to what it should be changed.

I know all the other workarounds, but like Steve, I just want it OFF. So:

  1. what to substitute for the 13.3 setting
  2. how to get permission to save the change.

R.

1
0

The terminal prompt totally worked for me! In Terminal.app copy paste the below:

sudo defaults write /Library/Preferences/FeatureFlags/Domain/Mail.plist RichLinks -dict-add Enabled -bool NO ; sudo chmod -R o+rX /Library/Preferences/FeatureFlags
1
0

This works as of MacOS Sonoma 14.2.1:

defaults write ~/Library/Containers/com.apple.mail/Data/Library/Preferences/com.apple.mail.plist AddLinkPreviews -bool false

To find other preferences, try:

defaults read ~/Library/Containers/com.apple.mail/Data/Library/Preferences/com.apple.mail.plist

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .