0

For some reason I cannot get MacOS Monterey to use the router I want.

I have a linux router on a virtual network which I tested as working (another VM on the same network can use the router just fine). On previous versions of MacOS (like Mohave) I would set the default gateway on the "Network Service" via System Preferences. Monterey doesn't allow for this (I see no way to create a "Network Service" via networksetup, and no detailed instructions anywhere on how to edit /Library/Preferences/SystemConfiguration/preferences.plist or if that would even work with Monterey). However, I still have a network interface and can ping the router, so I tried:

~> route delete default
~> route add default 10.37.129.3

Both commands execute without error. Any other machine on the network this works just fine, but not Monterey. I also tried it with the -ifscope flag to no avail. Routing table shows:

default            10.37.129.3        UGScIg      bridge101 

Does anyone know what's up or what to try next? I would also be keen to know if there is a way to create a Network Service for the network interface as that would make things easier like they were with previous MacOS versions. Thank you!

Edit: tcpdump on the router shows no traffic when I attempt to make Monterey route to it. It DOES show traffic when Monterey pings the router.

Edit#2: I managed to create a Network Service for the virtual network (editing /Library/Preferences/SystemConfiguration/preferences.plist) which then automatically sets the routing table to how I previously manually set it, but this doesn't fix the problem.

8
  • Do you have a DHCP server sending conflicting info somewhere on the network?
    – Tetsujin
    Nov 4 at 15:00
  • No, it only assigns IPs, no router. I just double checked.
    – Ball
    Nov 5 at 1:49
  • Result of "route get 8.8.8.8" looks correct, too
    – Ball
    Nov 5 at 17:40
  • route get just finds a route to the IP address you told it to. It doesn't confirm your gateway data. If you use DHCP, that's where you should tell it where to go for DNS. tbh, I don't know why you're trying to do any of this in the Mac, that's the gateway/router's job.
    – Tetsujin
    Nov 5 at 17:57
  • I have my very specific reasons, and your comment doesn't explain why it isn't routing (nor does it even attempt to). Maybe you should cut the snark?
    – Ball
    Nov 5 at 19:26

0

You must log in to answer this question.

Browse other questions tagged .