0

I'm holding a borrowed mac book, and I have created an admin account that can use Sudo and create new users, but in the system there exists another real admin account that I cannot reset the password with my current admin account. And when I want to upgrade the system, it requires me to input a password for that account. I also tried sudo softwareupdate -i [label], but it won't work: not install after downloading the install package.enter image description here

~ sudo softwareupdate -i 'macOS Ventura 13.0-22A380'
Password:
Software Update Tool

Finding available software
Downloading macOS Ventura 13.0
Password: 
Downloading: 100.00%
Downloaded: macOS Ventura 13.0
# after 100%
# I will get a notice that the update failed, as the figure attached
# and terminal will stacked in "Downloaded" forever..

Plus, I also tried to create an account with uid=0 as the root user to upgrade the system or reset the password for real admin account, failed.

The user id for that real admin account is 501, and the group is staff.

So I'm wondering if there is some super admin account in macOS?

9
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Nov 1, 2022 at 10:18
  • There is a root on Mac, by default disabled, & actually almost pointless because it has no more permission than is available to admin. It certainly won't let you make a duplicate & being able to access it won't gain you anything. The System Integrity Protection [SIP] was originally known as 'rootless'.
    – Tetsujin
    Nov 1, 2022 at 10:53
  • 501 is just the first user account created. To be clear, you've borrowed a Mac, and you're trying to get complete control over another user's (the owner's?) admin account?
    – benwiggy
    Nov 1, 2022 at 17:37
  • There is also no command system in a standard macOS, are you using a machine which is remotely managed?
    – nohillside
    Nov 1, 2022 at 18:17
  • 1
    I assume that you tried several times. Is your company blocking the upgrade maybe?
    – nohillside
    Nov 2, 2022 at 9:56

1 Answer 1

2

There is no higher user than admin, however, the admin is specifically and intentionally restricted by several design decisions. These changes are not all implemented on the same version of macOS so you may just need to boot to single user mode on older OS to make a change, or you may need to manage SIP or the system volume may be sealed, so you learn to modify a snapshot on the filesystem and alter the boot.

To address the specific issue - you probably are facing a secure token / bootstrap token issue.

Short term, you might be able to erase the system but not crack to bypass the security of the other admin password if you can't get the key.

2
  • Does that mean the only way to get the system upgraded is to unlock the system with a secure token or do the complex snapshot or filesystem modification(hacking)? Otherwise, I probably need to consider calling IT for this.
    – Yiffany
    Nov 1, 2022 at 11:10
  • 4
    @Yiffany As others commented already: Please ask a new question stating the problem you want to solve, the steps you take to solve it and where/how it fails. This will make it easier to get answers which actually help you to solve the problem.
    – nohillside
    Nov 1, 2022 at 11:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .