MacBook Air M1 won't connect to the external display (MSI MAG2732) in clamshell mode (power adapter connected to the device with lid off) after updating to macOS Ventura on October 24th (Day of release). I tried to use my updated iPad Air M1 as an external display 2, alongside the monitor as an external display 1. Turns out - after closing the lid, both of the display works! But as soon as the iPad is disconnected, the monitor loses signal (HDMI to USB-c cable).

I tried clearing/removing NVRAM, caches, and windowserver.plist files inside ~/Library/Preferences (couldn't find windowserver files, so any help on this would be highly appreciated!), and none of them worked. I also installed the macOS in safe mode again, changing the display refresh rate to default in both main and external displays. At this point, none of them seemed to work, and the only way I can use the external monitor is by keeping the lid on.

I also made sure that the system isn't falling asleep as soon as I turn the lid off. The system is not asleep when I close the lid, the application seems to be working and the external display also seems to be working normally, but no signals!

Update: External monitor seems to work with the lid closed in safe mode. It gets back to not working when restarted.

1 Answer 1


A problem immediately after updating to a new OS, which works normally in Safe mode, usually suggests some third-party background process that is incompatible with the new OS.

Check what LaunchAgents, LaunchDaemons and Login Items you are running.

Another easy and cheap fix: use a different cable or port.

I'm not sure why you think WindowServer would affect the connection to the display.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .